Tick() should accept a reference to the sample, not a pointer, to make it clear that it will never be null

RESOLVED FIXED in Firefox 55

Status

()

Core
Gecko Profiler
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: mstange, Assigned: njn)

Tracking

Trunk
mozilla55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
This would avoid warnings like bug 1346725 and help code clarity in my opinion.
(Assignee)

Comment 1

8 months ago
Created attachment 8857321 [details] [diff] [review]
Pass TickSample as a reference, not a pointer
Attachment #8857321 - Flags: review?(mstange)
(Assignee)

Updated

8 months ago
Assignee: nobody → n.nethercote
Status: NEW → ASSIGNED
(Assignee)

Updated

8 months ago
Duplicate of this bug: 1355383
(Reporter)

Comment 3

8 months ago
Comment on attachment 8857321 [details] [diff] [review]
Pass TickSample as a reference, not a pointer

Review of attachment 8857321 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8857321 - Flags: review?(mstange) → review+
(Assignee)

Comment 4

8 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ed2090cac956b4420f2e2fdeb1332d9a2585326
Bug 1347258 - Pass TickSample as a reference, not a pointer. r=mstange.

Comment 5

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4ed2090cac95
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.