Autophone - upgrade virtualenv installations

RESOLVED FIXED

Status

Testing
Autophone
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bc, Assigned: bc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
I believe that I have allowed the virtual environments used in the production servers to become far out of date with regard to the updated system packages. This *may* be the cause problem we continue to have regarding bug 1304063.

I have upgraded my local system and it appears to be working well though I haven't had a crash in the non-unittests yet:

https://treeherder.allizom.org/#/jobs?repo=autoland&filter-searchStr=autophone&exclusion_profile=false&group_state=expanded&fromchange=0bf31f0819dc20a0736803b814d4f88f95609031&tochange=1af0390360c1712f4010a3dea4b0ecc17a5c83f8

https://treeherder.allizom.org/#/jobs?repo=mozilla-inbound&filter-searchStr=autophone&exclusion_profile=false&group_state=expanded&fromchange=c7d1e31935ce5185b13f0e26dd1afc3d8aaaa875&tochange=f5f05a774023c7e9cc8eedbfbc91ba117f49274a

This is what I plan to do once my test finishes:

# Recreate the autophone virtual environment
virtualenv /mozilla/autophone/venv
# Activate it
. /mozilla/autophone/venv/bin/activate
# Upgrade
pip install --upgrade pip
pip install -r requirements.txt --upgrade
# Deactivate it
deactivate

# Recreate the phonedash virtual environment
virtualenv /mozilla/phonedash/venv
# Activate it
. /mozilla/phonedash/venv/bin/activate
# Upgrade
pip install --upgrade pip
pip install -r requirements.txt --upgrade
# Deactivate it
deactivate

jmaher, gbrown: Do you see any issues with this?
Flags: needinfo?(jmaher)
Flags: needinfo?(gbrown)
I think this is a great idea- it also helps with reproducibility of tests!
Flags: needinfo?(jmaher)
+1 - Sounds good to me.
Flags: needinfo?(gbrown)
(Assignee)

Comment 3

a year ago
Done 2017-03-14 ~ 15:30.

Note for phonedash I used pip install --upgrade templeton python-dateutil pytz since we don't have mysql installed.

Also, I got a warning when recreating the venv that it didn't overwrite python and that I should use python2. Looking at the venv bin directory however showed python and python2.7 are a soft links to python2 and their modification times match the installation time.

Everyone is back up and running. We'll see how this affects the error reporting.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.