Closed Bug 1347332 Opened 3 years ago Closed 2 years ago

Intermittent dom/media/test/test_background_video_suspend.html | gizmo-noaudio.mp4-1 suspended with a delay of 92.63 ms

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: kaku)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

The log says that gizmo-noaudio.mp4-1 is suspended SOONER than we expected, but at least it is suspended. This does not break anything at the moment, but I will still keep an eye on it, maybe add more logs to check what happened later.
Assignee: nobody → kaku
Status: NEW → ASSIGNED
Duplicate of this bug: 1347418
:kaku, thanks for looking into this- with 31 failures yesterday and we skip this job on many pushes (run it on linux opt every 5th push), the failure rate is a much higher percentage that 20%.  This appears to be opt/pgo and non-e10s only.

I will keep an eye on this as the failure rate puts this on the radar for a resolution by next week- let me know if there is more information I can help dig up!
Whiteboard: [stockwell needswork]
Duplicate of this bug: 1348088
See Also: → 1347421
See Also: → 1347954
Without any updates in this bug, it appears as if no one is working on this- the failure rate is very high and we would love to see this fixed soon.  One week out would be next Thursday and if the failure rate remains the same I will get a patch up for temporarily disabling this.  Ideally we won't need that as a fix will be close by.
Component: Audio/Video → Audio/Video: Playback
I apologize for not updating this bug, I thought I have done, but I didn't. 

The root cause is that the suspend-video-decoder is somehow mis-triggered before where we expected in the test_background_video_suspend.html, and bug 1347892 fix the issues of wrong policies for triggering suspend-video-decoder, so I believe bug 1347892 will fix this bug.
Depends on: 1347892
great, I assume we will see this in the next day or two!  Thanks for the fix :)
this seemed to have stopped on March 20th! I believe we can mark this as resolved!
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: [stockwell needswork] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.