NewsGroup Filters not converted from installed Netscape 4.79

RESOLVED INVALID

Status

MailNews Core
Profile Migration
P3
major
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Keypunch, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This is in regard to Windows NT 4.0 SP6a with all post SP6a Fixes/Hot
Fixes applied using Mozilla 0.9.9 2002031104.

When installed Mozilla the Newsgroup filters from the existing 4.79
Netscape were not converted over to to Mozilla.  It appears the .DAT
file containing the text information of the filters was copied over,
but a diff compare indicates the "mail" and "mail5" versions of the
.DAT file are identical.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKjvvfLzhJbmoDZ+EQKgDgCgjoKtDD82RhCW991V3gni2KbfhA8AoLJY
3NXRPOdoEWA8AwWhctT92Ype
=amLl
-----END PGP SIGNATURE-----
(Reporter)

Comment 1

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Changed "Component" from "Filters" to "Profile Migration", as suspect
the latter may better reflect the issue reported.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKj0hfLzhJbmoDZ+EQK6BwCfXSTr7UPfDC+RNBLYNljJ8Y6ajTsAoLAv
u4wcl9Ni2tO2D8M3AlzMta9f
=wP4C
-----END PGP SIGNATURE-----
Component: Filters → Profile Migration

Comment 2

16 years ago
changing owner and QA to reflect component
Assignee: naving → sspitzer
QA Contact: laurel → esther
(Reporter)

Comment 3

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Updated "Severity" from "Normal" to "Critical" as this issue does
result in loss of data in the configuration, thus requiring a manual
entry of the data not converted.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKkRUPLzhJbmoDZ+EQJNEgCg3XgAB4qg0Hs3bmn+/9ajyouC23IAoIMg
KHHQqNIQ6pGwkydRhyBlor83
=UAMZ
-----END PGP SIGNATURE-----
Severity: normal → critical

Comment 4

16 years ago
We don't support news filters yet in mozilla/6.x (bug 17483), so no news filter
rules info would be converted to a 6.x per account filter file for a news account.
Severity: critical → normal

Updated

16 years ago
QA Contact: esther → laurel
(Reporter)

Comment 5

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Umm, ok, but if not implemented yet, why is there a menu item that
actaully suggests the feature is implemented?  Would it not be better
to have the item grey out or it it needs to pup up as it does,
message text in the window that indicates this function is not
implemented yet?  Many other projects take the approach to display a
message to advise people the feature is not implemented yet.  I would
not suggest the greying out of the menu item as that can lead to
confusion if the feature is or is not working, as opposed to not
developed yet.

As side note, I think, but may be wrong, this issue was not in the
list of Frequent duplicate bugs.  Maybe that list should include
"prime" items not implemented yet as well?

I have to confess this is a very key feature to have.  Hint, hint,
nudge, nudge, wink wink! Ok, you get my drift here I am sure.

Updated "Severity" from "Normal" to "Major" as this issue does result
in loss of data in the configuration AKA "Severity" "Critical", but
may not require manual entry of the data as the filter data was
copied during the install.  The issue may just be case of reading the
existing filter data once the functionality is implemented.  Until
the functionality is implemented it will not be known if there is a
conversion issue of the rules from 4.x.


-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKkauPLzhJbmoDZ+EQLz0QCgtTnFW7aQK8997abrbVQmKLSGKoMAoLJX
oGrLgrLpQ9UueX9j6po54Bkr
=5mru
-----END PGP SIGNATURE-----
Severity: normal → major

Comment 6

16 years ago
Message Filters *are* indeed implemented. They work fine for IMAP or POP3
accounts, but we have not implemented it yet for newsgroups.  This bug is AFAIK
a duplicate of bug 17483 (or at least heavily dependant).
(Reporter)

Comment 7

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I would say this bug report is dependant, and not a duplicate.  The
context of this bug report is with the "migration" aspect.  Given no
current support for newsgroup filters, hence no migration is done,
then this is still an issue as the filters are in fact not
"migrated".

It is a seperate issue once newsgroup filtering is implemented if
there is an implied requirement for "import" or "manual" or
standalone program to convert the filter .DAT copied at migration
time to a "new" format shold that be a consequence of how the
newsgroup filters are implemented.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKk6KPLzhJbmoDZ+EQIg4gCg9CWpPfnPByvIe9y8UOyLg2KH/z0An1IA
9l4BSNDuy6k84A22M2A0VKz5
=GrIF
-----END PGP SIGNATURE-----

Comment 8

16 years ago
What I meant when saying it's a duplicate was of course that it should be
implemented at the same time as newsgroup filters are. But I am happy with
making this dependant (bugzilla-wise).

Confirming, clarifying summary and changing severity.
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Depends on: 17483
Ever confirmed: true
OS: Windows NT → All
Summary: NewsGroup Filters not converted from installed Netscape 4.79 → Newsgroup filters should be migrated from NS 4.x
(Reporter)

Comment 9

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Changed bug attributes as follows:

"Severity:" from "Enhancement"  to "Major"
"Summary:" from "Newsgroup filters should be migrated from NS 4.x" to
"NewsGroup Filters not converted from installed Netscape 4.79"
"Priority:" from "-" to "P3"
"Platform:" from "PC" to "All", to be consistant with prior "OS"
change made.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKp8PfLzhJbmoDZ+EQLZ1gCg35shQsMiKSsiIJN364WCCmpibjkAn3du
8+9D3rrjaFrShe0aVg7AuWz2
=jhl2
-----END PGP SIGNATURE-----
Severity: enhancement → major
Priority: -- → P3
Hardware: PC → All
Summary: Newsgroup filters should be migrated from NS 4.x → NewsGroup Filters not converted from installed Netscape 4.79

Comment 10

16 years ago
Mr Males: Please be so kind as to disable your PGP signature when posting to
bugzilla, thanks.

Comment 11

16 years ago
invalid. stop pgp signing bugzilla comments. we don't care if people 
impersonate you, as long as they don't include noise.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 17483
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.