Closed Bug 1347431 Opened 3 years ago Closed 3 years ago

Skip some xpcshell tests that is failure on Android without ENABLE_INTL_API

Categories

(Core :: Internationalization, defect, P2)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(2 files)

No description provided.
Blocks: 1343725
Comment on attachment 8847905 [details]
Bug 1347431 - Skip some xpcshell tests that is failure on Android without ENABLE_INTL_API.

https://reviewboard.mozilla.org/r/120828/#review122962
Attachment #8847905 - Flags: review?(snorp) → review+
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/985cd7df1397
Skip some xpcshell tests that is failure on Android without ENABLE_INTL_API. r=snorp
https://hg.mozilla.org/mozilla-central/rev/985cd7df1397
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Comment on attachment 8849480 [details] [diff] [review]
Rebase for aurora

Approval Request Comment
[Feature/Bug causing the regression]:
bug 1343725

[User impact if declined]:
We cannot release Firefox for android on beta and release channel since it doesn't pass xpcshell test on beta/release builder.

:snorp and :blassey decides that we still keep turning off Intl API and ICU on Fennec beta/release channel.  So we require this fix to build Fennec on release and beta channel.

[Is this code covered by automated tests?]:
Yes

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
No, this is automation test issue.

[List of other uplifts needed for the feature/fix]:
Nothing.

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Skip test that doesn't work without ICU.

[String changes made/needed]:
No
Attachment #8849480 - Attachment description: For aurora → Rebase for aurora
Attachment #8849480 - Flags: approval-mozilla-aurora?
Comment on attachment 8849480 [details] [diff] [review]
Rebase for aurora

Skip the failed tests w/o ENABLE_INTL_API. Aurora54+.
Attachment #8849480 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.