Multiprocess in Firefox 52 not available/not working

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
10 months ago
7 months ago

People

(Reporter: -, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

Nothing, Firefox never told us users that a multiprocessing function is available.


Actual results:

I randomly had a look at the new features of Firefox 52. I noticed the updated responsive design/web developer thing and read in the yellow info box that it's only available when multiprocessing is enabled. As my Firefox crashes a lot anyway and this might help, I wanted to enable that function.

I couldn't find any way to do that. There's no box to be ticked in the general tab of the preferences and in about:support the "Multi-process staged rollout" says true, but it's not working. I've also read that add-ons can cause it to be disabled, but I don't want to enable each single one to find the culprit. Is there a website that tests or lists which add-ons don't work with multiprocess?


Expected results:

According to sources on the net, there should be a box to be ticked in the preferences to enable multiprocess. Also Firefox should have informed us that this function is now available.
(Reporter)

Comment 2

10 months ago
Had a second look at about:support and noticed that in my German Firefox version, I shouldn't look at "Multi-process staged rollout", but rather "Fenster mit mehreren Prozessen".

There's indeed a zero because of an add-on. Do I really have to deactivate all of them and reactivate them one by one, restarting Firefox everytime, till I know which one it is?
Hi,

Can you please retest using a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/AR5o9d)?

Also please provide your Extensions list from about:support.
Flags: needinfo?(formicula)
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

7 months ago
What other information should I provide? Just add an option to switch that function on/off in the preferences.
Flags: needinfo?(formicula)
You need to log in before you can comment on or make changes to this bug.