Closed Bug 13475 Opened 20 years ago Closed 20 years ago

[Regression] Apprunner crashes when you close and re-open Messenger

Categories

(MailNews Core :: Backend, defect, P3, critical)

All
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: pmock, Assigned: scottputterman)

References

Details

Build Date & Platform Bug Found:
 Win32 seamonkey build 1999-09-09-08-m10 installed on HP P450, NT 4.0
 Linux seamonkey build 1999-09-09-08-m11 installed on Compaq P200 RedHat 6.0
 MacOS seamonkey build 1999-09-09-08-m11 installed on G3/400 Mac OS 8.5.1

Overview Description:
 Messenger crashes when you close messenger and re-open it from the browser
window.  This problem occurs when clicking on the messenger icon on component bar
or through the Task menu selecting messenger.

Steps to Reproduce:
1) Launch Apprunner
2) Click on the messenger icon off the component bar or through the task menu
option "Messenger"
3) Wait for the Messenger window to open then Close the messenger window.
4) Launch Messenger again
   Apprunner crashes.

Actual Results:
 Apprunner immediately crashes.

Expected Results:
 The messenger window should open again.  It should not crash the application.

Additional Builds and Platforms Tested On:

Additional Information:
 Regression... This was working in yesterday builds
Warren was seeing this today too. I actually just tried it out myself. Here's
the stack trace before the assertion that leads to the crash:
nsServiceEntry::RemoveListener(nsIShutdownListener * 0x03d7dc04) line 92 + 31
bytes
nsServiceManagerImpl::ReleaseService(nsServiceManagerImpl * const 0x00e51950,
const nsID & {...}, nsISupports * 0x00f3e690, nsIShutdownListener * 0x03d7dc04)
line 283 + 12 bytes
nsServiceManager::ReleaseService(const nsID & {...}, nsISupports * 0x00f3e690,
nsIShutdownListener * 0x03d7dc04) line 453 + 30 bytes
nsMsgRDFDataSource::~nsMsgRDFDataSource() line 39 + 46 bytes
nsMsgRDFDataSource::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsMsgRDFDataSource::Release(nsMsgRDFDataSource * const 0x03d7dc00) line 64 + 96
bytes
nsServiceEntry::RemoveListener(nsIShutdownListener * 0x03d7dc04) line 88 + 12
bytes
nsServiceManagerImpl::ReleaseService(nsServiceManagerImpl * const 0x00e51950,
const nsID & {...}, nsISupports * 0x00f3e690, nsIShutdownListener * 0x03d7dc04)
line 283 + 12 bytes
nsServiceManager::ReleaseService(const nsID & {...}, nsISupports * 0x00f3e690,
nsIShutdownListener * 0x03d7dc04) line 453 + 30 bytes
nsMsgRDFDataSource::~nsMsgRDFDataSource() line 39 + 46 bytes
nsMsgFolderDataSource::~nsMsgFolderDataSource() line 115 + 27 bytes
nsMsgFolderDataSource::`scalar deleting destructor'(unsigned int 1) + 15 bytes
NS_NewMsgFolderDataSource(const nsID & {...}, void * * 0x0012f300) line 1275 +
31 bytes
nsMsgFactory::CreateInstance(nsMsgFactory * const 0x03b4b2a0, nsISupports *
0x00000000, const nsID & {...}, void * * 0x0012f300) line 266 + 13 bytes


Since msg rdf data source is on the stack, I'd like to assign this to putterman
if that's okay with you Phil?
Assignee: phil → putterman
Thanks for the stack trace ScottM. Bad news for you ScottP :-)
*** Bug 13588 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reopening since the crash is occuring again.
Build 1999091509M11: Win32/NT4, Linux/Redhat 5.0
(Mac: Haven't check due to Smoke Test problems)

On NT4 when I relaunch mail through the Navigator menu, Tasks/Messenger, it
tries to draw the Mail window but then crashes. I have to Ctrl-Alt-Del and End
the task. On Linux, Messenger never attempts to draw a window, it just crashes.

Workaround: I noticed if I close Mail using the close box, "x", in the top right
corner then the crash does not occur. If I use the File/Close menu then it
crashes.
Target Milestone: M11
M11
Severity: major → critical
Summary: [Reqression] Apprunner crashes when you close and re-open Messenger → [Regression] Apprunner crashes when you close and re-open Messenger
upgrading the severity of this.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I checked in a fix.
Status: RESOLVED → VERIFIED
Win32 (1999-10-26-09-M11)
 Linux (1999-10-26-08-M11)
 Mac (1999-10-26-09-M11)
 Apprunner NO LONGER crashes when you close and re-open Messenger.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.