Subscribed Newsgroup Names Incorrectly Listed

VERIFIED DUPLICATE of bug 61794

Status

MailNews Core
Networking: NNTP
--
major
VERIFIED DUPLICATE of bug 61794
16 years ago
9 years ago

People

(Reporter: Keypunch, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This in regards to Windows NT 4.0 SP6a with all post SP6a Fixes/hot
Fixes applied using Mozilla 0.9.9-2002031104.

No matter what size the Mail/Newsgroup Folder Tree is the names of
the subscribed newsgroups is not correctly listed.  One example would
be tor.jobs is listed as t.jobs, kw.jobs is listed as k.jobs, ect. 
To gain a better sense of the issue I will upload a screen capture
file called
"mozilla-0.9.9-2002031104-20020401-Newsgroup-ShortNewsgroupName.png"
to help clarify the reported issue.  It appears I will have to upload
the file after submitting this initial problem statement.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKj3kPLzhJbmoDZ+EQLI0ACgw1s0fWknSEgVdGgrsnbtn0D+H40AnAuz
vlDi3e5G2/ogByWNlNPxmXGT
=lkDv
-----END PGP SIGNATURE-----
(Reporter)

Comment 1

16 years ago
Created attachment 77131 [details]
Example Screen shot of Problem Reported

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Example screen shot file
"mozilla-0.9.9-2002031104-20020401-Newsgroup-ShortNewsgroupName.png"
of reported issue.

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKj4Y/LzhJbmoDZ+EQJxNwCfS1nSk5dBQ94/O6zGoZftXFBx5FoAn3Zt
0oLaY/rNTjC9kq1v5AUS4WIl
=kClO
-----END PGP SIGNATURE-----

Comment 2

16 years ago
John, It's a Feature, Not a Bug! (tm)  :-)

No really, it is. There's a hidden preference, that you can put in your prefs.js
if you want to show the full names of the newsgroup (I'm sure Stephen or Seth
can enlighten me of the exact pref-name). Because in most cases you wouldn't be
able to see the full name of the newsgroup anyway, we have decided to truncate
it -- and most users seem to be satisfied with this. My advice: use the pref if
you are really annoyed.

Are you OK with resolving this bug as WORKSFORME?

BTW, please don't attach a PGP signature to your bugzilla comments and reports.
 Thanks!
(Reporter)

Comment 3

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Håkan Waara,

LOL LOL ok I been around far to long to know the "It's a Feature, Not
a Bug! (tm)  :-)" one, AKA as I call it "Working as coded." :))

Ok, seriously, here are my thoughts.  I feel that this bug has
circulated about in various forms for over 2 years now and needs to
be addressed.  The reason I take that view is for the average
non-technical user changing a .js configuration file is just not a
reasonable expectation.  There should be a GUI based option to set
this .js item per the user preference based on these prior bug
reports:

Bug 97899 - that claims the issue was fixed?
Bug 61794 - control the "abbreviate" pref. - but never explains the
"workaround", and indicates that there should be a UI level
configuration as I mentioned above 
Bug 23633 - Similar issue to this bug reported over 2 years ago!
Bug 133956 - Abbreviation names sometimes excessive, dup/related of
Bug 23633 (or Bug 61794 or Bug 61795);
Bug 61794 depends on Bug 63679
Bug 105628 - Newsgroup abbreviation should be optional, needs
tooltips, dup of Bug 23633
Bug 63679 - put "push auth" and the "abbreviate" prefs


Related in other ways:

Bug 98047 - about the scheme used to abbreviate, and is dup of Bug
61795
Bug 61795 - number of sub-levels that aren't abbreviated, dup of Bug
61794


Personally the default preference should be to list the full length
of the newsgroup name.  I base this on two reasons, first and most
important it is the most reasonable mindset, second Bug 23633 eludes
to fact the root cause of the issue is the ability to "know" the size
of window so the names can self adjust in size.

If you were to ask me for a solution I suggest a "expanding/colapsing
tree"  Much like how Netscape 4.x presents all the downloaded
newsgroups a user then slects from for the groups they wish to
subscribe to.  Oddly even Netscape 4.x does not do this with the
groups subscribed to for a newsgroup server, only when downloading
the entire list for the user to select from.  Seems odd to me it was
never extended to the news server subscribed to list as well.

Having said all this, here is what I propose:

 1) This bug be changed to confirmed
 1) This bug is assigned to the person that can detail out in this
bug the change one makes to the .js file that allows the full name to
be displayed.
 2) I then confirm that (1) above does in fact work.
 3) I will then close this bug with a "Resolution" of "Later" on the
condition that I make it realted/duplicate of Bug 23633, Bug 97899,
Bug 61794, Bug 105628, and Bug 63679.
 4) I am added to the CC list of interested parties for Bug 23633,
Bug 97899, Bug 61794, Bug 63679, Bug 98047, Bug 61795, Bug 61794, Bug
133956, and Bug 105628.

Thoughts on this Håkan?

-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKk3efLzhJbmoDZ+EQJ6EgCguHStLmsv590YYNE1Moz/p94fwrIAoN39
5X4zUu5VZdz5BVaC4EKvVwrA
=KKQc
-----END PGP SIGNATURE-----

Comment 4

16 years ago
I still don't think this is a bug. You should note that a tooltip will appear
over the newsgroup if you hover over it, with the full newsgroup's name. This is
IMHO sufficient, and we don't need Yet Another Pref (we have extremely many of
them already!) to control such a detail.

We have the tooltip feature, and we have the hidden pref one, that is more for
advanced users. As I said before, most users seem to be satisfied with those
options.

I will resolve this as a duplicate bug of Bug 61794 , but really, I think that
should be wontfix. We have too much bloat in our UI already.

Please read http://www.mozilla.org/quality/bug-writing-guidelines.html ; don't
attach your PGP signature, and don't resolve bugs as LATER or REMIND.

Thanks.

*** This bug has been marked as a duplicate of 61794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

16 years ago
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

It seems to me I was asked per 

http://bugzilla.mozilla.org/show_bug.cgi?id=134751#c2

"Are you OK with resolving this bug as WORKSFORME?"

It appears to me that the suggestions I made in my reply 

http://bugzilla.mozilla.org/show_bug.cgi?id=134751#c3

were just ignored and actions were taken on "this" bug without
further discussion with me.  So what was the point of asking me to
begin with?  If this is the approach and "attitude" that will be
taken with "users" I can assure you that "choice" will excercise
their choice options.  I think an intelligent person can deduce the
implications.

I happen to be a Professional QA/Testing Professional, and speak from
experience about users and their expectations.  That is exactly the
point of reference I am using.  That means I put "my personal" views
aside and look at it from the user's perspective.  That requires
being objective and not emotional in perspective and making
decisions.  I suggest perhaps viewing matters in the context of the
average non-technical user's perspective.  That is the audience this
browser is aimed for.

With all due respect this bug was closed without even documenting the
.js file edit that will allow the full names to be displayed as
requested.  So how has this helped anyone?  In fact in none of the
bugs I have cited have documented the specifics as best I can tell. 
If this .js option has been documented then either advise which bug
it is documented in or document the "workaround" in this bug.  I have
look Hi and Low via search and cannot located the "documented"
workaround, yet other bugs do "elude to this .js option.

The proposed tooltip workaround to see the full newsgroup name does
not work at all for me.  That means I hover the mouse over the name
and NO TOOLTIP APPEARS.  I even tried this before I opened this bug,
and I have tried it since on several occasions.  Sorry, no tooltip is
showing.  If one had I would have noted that fact in my initial
problem description and factored into my the severity of "this" bug. 
Bug 23633 in reference to tooltips on this bug issue noted that it
"is a bandaid approach to a poor design".  See:

http://bugzilla.mozilla.org/show_bug.cgi?id=23633#c9

Now if there is no desire to leave "this" bug open due to the other
existing bugs that is fine, but then the issue is which one of the
related bugs I listed is the "final" solution?  As at the time of
writing it seemed fair to assume there were two basic schools of
thought.

One that the initial problem was the inability to sense the size of
the subwindow the newsgroup names were in.  There is a need to match
the functionality that had been in Netscape 4.x.  See Bug 23633 for
the details.  Specific Bug 23633 references:

http://bugzilla.mozilla.org/show_bug.cgi?id=23633#c6 states:

Suggest adding keyword 4xp since 4.x only abbreviated newsgroup names
if necessary. 

http://bugzilla.mozilla.org/show_bug.cgi?id=23633#c9 states:

I agree that the "tooltip/help text" helps, but it is a bandaid
approach to a poor design.  When you have, perhaps, dozens of
newsgroups in your list it quickly becomes very frustrating to find
out what the real names are.  Turning off abbreviation in the prefs
just abbreviates the end of the string, with is worse still.  If
you're trying to win back netscape 4.7x users as well as new ones,
you should at least have taken the best functions from 4.7x and used
them.


http://bugzilla.mozilla.org/show_bug.cgi?id=23633#c14 From Håkan
Waara states:

A UI for this would be ridiculous, we should provide visible UI only
for those prefs that do matter. I don't consider whether the
newsgroups-names should be truncated or not to be one of them. 
However, I think it sounds like an excellent idea to make the
folderpane 'smart' and figure out if it should unabbreviate the
groups upon resizing the splitter - so if the names would fit, they
will expand to use the full newsgroupname.


http://bugzilla.mozilla.org/show_bug.cgi?id=23633#c15 From
putterman@netscape.com states:

reassigning to sspitzer.  Yeah, we defintely need to make this
smarter based on
the amount of space available.  Numerous alorithms have been posted
in the
newsgroups.


The other option is to fully display the newsgroup names.  this
appears to be related to the .js file option that has not been
documented yet and implementing a UI option to actually set the .js
option re Bug 61794. 

The setting of the .js file "option" has secondary issues both short
term and long term that I will skip noting for the moment.

Therefore it is appropriate to reopen this bug until the issues are
addressed and negotiated with the parties involved. 





-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 6.5.8 for non-commercial use <http://www.pgp.com>
Comment: .

iQA/AwUBPKp3wfLzhJbmoDZ+EQJnAQCfVlSNv0Idu1w0IkabMQ0NLEZVEEkAoN1s
xSmJmBOEUnX/hjhFOjEhQ/5U
=hh8p
-----END PGP SIGNATURE-----
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

16 years ago
This bug is a dupe.  You want UI for the pref.  61794 is what you want.  Please
don't reopen it again.  Also, please stop using your pgp stuff in here, it's
annoying and takes up space, and is of no use to anyone.

*** This bug has been marked as a duplicate of 61794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
__Please__ stop signing each and every bugzilla post with your PGP signature. 
This is HTML, not email.

http://www.mozilla.org/mailnews/specs/ is where the Mozilla Mail/News specs
live, where we implement and verify features against.

In this bug, you have clearly stated the bugs you'd like to see fixed.  We've
pointed you to the bug responsible for turning on the behavior that displays the
full newsgroup names.

There are also other bugs, namely bug 32157, which provides for an automatic
tooltip on hover (hwaara missed this one).

http://bugzilla.mozilla.org/show_bug.cgi?id=61794 (first comment) contains a
link to:

news://news.mozilla.org:119/3A2857EE.10004%40netscape.com

which describes the pref:

(quoting Seth)
It is a preference, but not in the UI.  (I thought at one point it was, but I
can't find it now.)

You can turn it off on a per server basis.  By default, it is on.  to change the
default, add this to your prefs.js file:

user_pref("mail.server.default.abbreviate",true);

If you want to override it per server, replace "default" with the server id,
example "server3". 
(/quote)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.