Closed Bug 1347588 Opened 5 years ago Closed 3 years ago

Crash in shutdownhang | libglib-2.0.so.0.4002.0@0x473e7

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect, P3)

All
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox52 --- wontfix
firefox-esr52 --- fix-optional
firefox53 --- fix-optional
firefox54 --- fix-optional
firefox55 --- fix-optional
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- ?

People

(Reporter: emilghitta, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-121c654b-f41f-4b06-88e8-6d8ef2170315.
=============================================================

[Affected versions]:
Firefox Release 52.0
Firefox Beta 53.0b2 
Firefox Latest Aurora  54.0a2
Firefox Latest Nightly 55.0a1 

[Affected platforms]:
Ubuntu 

[Steps to reproduce]:
1. Launch Firefox
2. Access the https://www.dropbox.com/ webpage
3. Log In
4. Drag and drop multiple files (at the same time) in order to upload them
5. Click the Upload button
6. Click the Add more files button
7. Restart Firefox from the Developer Toolbar (shift+F2 and type: restart)
8. Observe that Firefox delays the restart and crashes after approximately 30 seconds.

[Expected result]:
Firefox is not hanging and it successfully restarts.

[Actual result]:
Firefox hangs when the “Add more files” button is pressed and if the user restarts Firefox from the Developer Toolbar,Firefox,crashes after 30 seconds.

[Regression range]:
I didn’t manage to discover the regression range for this issue, but i will come back to this as soon as possible.

[Additional information]:
This issue is not reproducible on Mac  and Windows Oses.
I will come back as soon as possible with a regression range and a video for this issue.
Flags: needinfo?(emil.ghitta)
Please access the following link in order to observe the reproducible issue:
https://drive.google.com/file/d/0B94iuIVMr-TEWVVUMHZXbFBWd2M/view?usp=sharing

I have tried to find the regression range for this issue but it is very time consuming, this issue goes back to old Nightly from 2015-05-01 (Crash Signature bp-8264a3a1-aef3-441c-85d8-1b9942170323).

I didn't manage to reproduce this issue on old Nightly from 2015-04-27: 
Here is the pushlog from 2015-04-27 to 2015-05-01 ( I hope that this may be of help):
https://hg.mozilla.org/integration/autoland/pushloghtml?startdate=2015-04-27&enddate=2015-05-01

If you have any question please don’t hesitate to needinfo me.
Flags: needinfo?(emil.ghitta)
Priority: -- → P3
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.