15.97 - 20.97% tresize (windows7-32, windows8-64) regression on push 7e35e5f2b9dfb5539598e67e3b08502e111be353 (Mon Mar 13 2017)

RESOLVED DUPLICATE of bug 1347545

Status

()

defect
RESOLVED DUPLICATE of bug 1347545
2 years ago
2 years ago

People

(Reporter: rwood, Assigned: johannh)

Tracking

({perf, regression, talos-regression})

53 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
Talos has detected a Firefox performance regression from push 7e35e5f2b9dfb5539598e67e3b08502e111be353. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 21%  tresize windows8-64 pgo      10.22 -> 12.36
 16%  tresize windows7-32 pgo      9.13 -> 10.59


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=5442

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Assignee

Comment 1

2 years ago
It's highly unlikely that this patch was the cause of the regression, sorry. The patch replaces an unneeded function in a test file with a utility function. I don't see how this would cause a performance hit in the application.

That's all from my side, I'm not sure how to help you with this. Please redirect to the correct cause.
Assignee

Updated

2 years ago
Flags: needinfo?(rwood)
Assignee

Updated

2 years ago
Assignee: meghanagupta3 → jhofmann
Looking at the graphs, this test went bimodal after bug 1346644 landed, that is almost certainly the root cause here. Let's dupe this to the already-filed bug 1347545 tracking that.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1347545
Flags: needinfo?(rwood)
You need to log in before you can comment on or make changes to this bug.