Closed Bug 1347743 Opened 3 years ago Closed 3 years ago

update adb/fastboot to the latest Android API release

Categories

(DevTools Graveyard :: WebIDE, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kbrosnan, Assigned: kbrosnan)

Details

Attachments

(1 file)

No description provided.
No longer blocks: b2g-addon
No longer depends on: 1059081, 1165830
Bah overeager enter submission.

I have updated adb/fastboot in adbhelper to the latest release from https://developer.android.com/studio/releases/platform-tools.html this provides support for modern Android devices. I have tested this with local replacement of the files on Nightly. I tried building the addon from source but since I need to use a different addon name to get it signed it won't connect with the webIDE.
Whiteboard: [spark][systemsfe]
Assignee: nobody → kbrosnan
Comment on attachment 8847830 [details] [review]
Update to platform tools 25.0.3

I suspect you want to do minimal work with this extension as there are plans to replace the webide. However the two year old adb won't see my Nexus 5x and some other modern Android devices. Which makes connecting to Firefox for Android on the devices a pain. This is a straight copy of the files from https://developer.android.com/studio/releases/platform-tools.html to the relevant directories.

Android has dropped support for their development tools on Linux 32-bit so those files have not been updated.
Attachment #8847830 - Flags: review?(jryans)
Hmm, do you know any more about the issue you are seeing?  I am just curious how many people might be affected.  I have a Nexus 5X with Android 7.1.1 and the existing add-on version appears to connect as expected.
Flags: needinfo?(kbrosnan)
I'm on Windows.
Flags: needinfo?(kbrosnan)
(In reply to Kevin Brosnan [:kbrosnan] from comment #5)
> I'm on Windows.

Okay, that could be it, I am on macOS 10.12.3.  Let's proceed!
Released as 0.10.0.

https://github.com/mozilla/adbhelper/commit/3064039c662cf29931181b7f9b0e10fedcf3ef07

Thanks for working on this!
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I'll do some testing on the three platforms tomorrow.
I have tested v0.10.0 on all three platforms and all devices I've tested are connecting to the WebIDE.
(In reply to Kevin Brosnan [:kbrosnan] from comment #9)
> I have tested v0.10.0 on all three platforms and all devices I've tested are
> connecting to the WebIDE.

Great, thanks for testing this! :)
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.