If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bugzilla needs a XUL interface

VERIFIED DUPLICATE of bug 48822

Status

()

Bugzilla
User Interface
P3
enhancement
VERIFIED DUPLICATE of bug 48822
16 years ago
5 years ago

People

(Reporter: Chris Charabaruk, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
With all the power provided by XUL on Mozilla, why is it that we still have to
use HTML to file or work on bugs? It's high time that we have a XUL application
for Bugzilla work.
(Reporter)

Comment 1

16 years ago
(I should have put this in the original description, sorry for the spam)

This isn't meant as an April Fool's joke, /. pretty much turned me off of those
today. Seriously, we should be able to have a XUL interface for Bugzilla, we've
seen that it's possible to have remote XUL apps with XUL Minesweeper.

Comment 2

16 years ago
are you looking for 1) remote xul where bugzilla sends you xul files or 2) an 
application like chatzilla which presents a xul ui to data being requested 
from bugzilla?
(Reporter)

Comment 3

16 years ago
Option 1 (remote XUL), just like XUL Minesweeper is. Though if the other is
easier to do, I guess that would be better. Either way, there would have to be
changes to Bugzilla, as far as I can tell.

Comment 4

16 years ago
alot of those changes are already in or in the works. There are (will be) 
ways of getting XML back from a query instead of HTML and a XUL app 
could consume something like that and display it in interesting new ways.

I'm sure Myk has ideas already in this direction.
(Assignee)

Comment 5

16 years ago
Yes, I have some ideas and some code as well.  I'll get it cleaned up and posted
asap.
Priority: -- → P4
Target Milestone: --- → Future
(Assignee)

Updated

16 years ago
Priority: P4 → P3
Target Milestone: Future → Bugzilla 2.18

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 48822 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
removing target on DUPL/WONTFIX (so they'll show up as untriaged if reopened)
Target Milestone: Bugzilla 2.18 → ---

Comment 8

16 years ago
Verified dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.