getChannelData on (non-existent?) channel silently breaks execution

RESOLVED FIXED

Status

()

Core
Web Audio
P2
normal
Rank:
25
RESOLVED FIXED
10 months ago
4 months ago

People

(Reporter: rocca.joseph, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. Go to this link: https://jsfiddle.net/umgmmqvp/2/
2. Open up console
3. Observer that the execution of the program abruptly stops at line 36 (`console.log(audioBuffer.getChannelData(1).length);`).


Actual results:

It seems to silently break the program and prevent further execution when I try to grab channel 1.


Expected results:

If there is no channel 1 available then I'd expect it to throw an error message.
(Reporter)

Comment 1

10 months ago
Actual, use https://jsfiddle.net/umgmmqvp/3/ instead (slight fix to remove `.length` on line 36, because it is not relevant to this bug report). Sorry for the double post - I couldn't work out how to edit the original report.

Updated

10 months ago
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P2
I can't repro in nightly. Please reopen if you can still reproduce.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.