Ensure locales other than en-US have access to KB discussions

RESOLVED FIXED

Status

support.mozilla.org - Lithium
Localization
RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: John99, Assigned: vesper)

Tracking

Details

Ensure locales other than en-US also have access to KB discussions in order to help with localisation work and decisions.

User Story
I see an article history (as do any visitors to Sumo) & wish to know more about the changes or proposed changes to the article. This information is often in the form of contributor comments. 
Such information helps me understand the reasons for the changes.
It may also indicate reasons for not yet marking for localisation, and further information on pending or future revisions.
Am I able to see those discussions? if I am using a locale other than en-US.
See also Bug1337669 & Bug1347876 .
(Reporter)

Updated

11 months ago
Blocks: 1348889
(Assignee)

Comment 1

11 months ago
(In reply to John Hesling [:John99] (NeedInfo me) from comment #0)
> Ensure locales other than en-US also have access to KB discussions in order
> to help with localisation work and decisions.
> 
> User Story
> I see an article history (as do any visitors to Sumo) & wish to know more
> about the changes or proposed changes to the article. This information is
> often in the form of contributor comments. 
> Such information helps me understand the reasons for the changes.
> It may also indicate reasons for not yet marking for localisation, and
> further information on pending or future revisions.
> Am I able to see those discussions? if I am using a locale other than en-US.
> See also Bug1337669 & Bug1347876 .

Hi John,

Every SUMO contributor should have access to the "Comments" section under every article if they have the right permissions.

If any contributor does not see the section, they should contact me or flag it to any other SUMO admin - and they will be set up with the right permission for this to happen.
(Reporter)

Comment 2

11 months ago
(In reply to vesper from comment #1)
> ... ...
> Hi John,
> 
> Every SUMO contributor should have access to the "Comments" section under
> every article if they have the right permissions.
> 
> If any contributor does not see the section, they should contact me or flag
> it to any other SUMO admin - and they will be set up with the right
> permission for this to happen.

Hi Michal,  
Thanks for the reply. 
How do other users do this how and where do they need to navigate to? 

As say a German French or Italian user how would I do it.
My KB articles would obviously be shown in my native language.
It therefore occurred to me that the en-US discussions probably would not be available. 

I presumably can not test this as I will no longer have required permissions in other locales but how do they go about navigating to the English KB discussions ?   
My concern is that with per locale permissions none en-US locales would not be able to access en-US discussions.
(Assignee)

Updated

10 months ago
Assignee: nobody → mdziewonski
(Assignee)

Comment 3

9 months ago
The en-US discussions are only visible under the en-US articles. (e.g. https://hwsfp35778.lithium.com/t5/Basic-Browsing/How-to-set-the-home-page/ta-p/3478)

Finnish discussions are only visible under the fi articles. (e.g. https://hwsfp35778.lithium.com/t5/Verkon-selaus/Aloitussivun-asettaminen/ta-p/8215 - the Finnish version of the English article above)

Any SUMO contributor should see all the discussions under all articles in all locales - there should be no difference in interacting with that part of the content, as long as you are a logged in SUMO contributor with the right role.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
(Reporter)

Comment 4

9 months ago
Michal have you tried using that link ?? because it does not work for me. It defaults to another home page. 
Maybe it hass only recently been broken.
>  (e.g. https://hwsfp35778.lithium.com/t5/Basic-Browsing/How-to-set-the-home-page/ta-p/3478)

I will reopen this.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
(Assignee)

Comment 5

9 months ago
I'm closing this, as the discussions work as expected. The example link being broken is related to a different bug and a different issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1370422
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.