Crash in nsImapProtocol::SetupWithUrlCallback

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
8 months ago
7 months ago

People

(Reporter: Thomasy, Unassigned)

Tracking

({crash})

Trunk
Thunderbird 54.0
x86
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 months ago
This bug was filed from the Socorro interface and is 
report bp-5d04d8d4-07b6-4eae-88a5-3cf992170316.
=============================================================

After uninstall Word 2017 KB3178674 update. It won't crash.
status-firefox55: affected → ---
Component: Networking → Untriaged
Product: Core → Thunderbird
Target Milestone: --- → Thunderbird 54.0
Thomas, can you reproduce this with a current Daily (TB 55) and Earlybird (TB 54a2).

Some code has changed in this area recently and TB 54a1 does no longer exist. Also the crash location reported here:
https://crash-stats.mozilla.com/report/index/5d04d8d4-07b6-4eae-88a5-3cf992170316
nsImapProtocol.cpp:894
doesn't contain code that could possibly crash. Most likely the code was modified since the version (installed/compiled on 2017-03-05 23:59:51) that produced the crash:
https://hg.mozilla.org/comm-central/log/tip/mailnews/imap/src/nsImapProtocol.cpp
Flags: needinfo?(thomas)
(Reporter)

Comment 2

8 months ago
(In reply to Jorg K (GMT+1) from comment #1)
> Thomas, can you reproduce this with a current Daily (TB 55) and Earlybird
> (TB 54a2).
> 
> Some code has changed in this area recently and TB 54a1 does no longer
> exist. Also the crash location reported here:
> https://crash-stats.mozilla.com/report/index/5d04d8d4-07b6-4eae-88a5-
> 3cf992170316
> nsImapProtocol.cpp:894
> doesn't contain code that could possibly crash. Most likely the code was
> modified since the version (installed/compiled on 2017-03-05 23:59:51) that
> produced the crash:
> https://hg.mozilla.org/comm-central/log/tip/mailnews/imap/src/nsImapProtocol.
> cpp

Jorg, it wont crash now even with KB3178674 installed. Test with Earlybird 2017-03-06 zh-TW and Daily 2017-03-05 zh-TW.
Flags: needinfo?(thomas)

Comment 3

8 months ago
Nothing on crash stats after buildid 20170305030206 nightly build. Perhaps bug 791645 helped?

Thomasy, you are still running that old build and crashed recently bp-127dac56-1dfc-4814-8fb3-4a07a2170324 below - I'm curious why you are still running that build?  Do you still crash if you update to a newer version of THunderbird daily?  (I doubt KB3178674  has anything to do with this)

 0 	XUL	nsImapProtocol::SetupWithUrlCallback(nsIProxyInfo*)	/builds/slave/tb-c-cen-m64-ntly-000000000000/build/mailnews/imap/src/nsImapProtocol.cpp:894
1 	XUL	non-virtual thunk to nsImapProtocol::OnProxyAvailable(nsICancelable*, nsIChannel*, nsIProxyInfo*, nsresult)	/builds/slave/tb-c-cen-m64-ntly-000000000000/build/mailnews/imap/src/nsImapProtocol.cpp:852
2 	XUL	mozilla::net::nsAsyncResolveRequest::DoCallback()	netwerk/base/nsProtocolProxyService.cpp:280
3 	XUL	mozilla::net::nsAsyncResolveRequest::Run()	netwerk/base/nsProtocolProxyService.cpp:156
4 	XUL	nsThread::ProcessNextEvent(bool, bool*)	xpcom/threads/nsThread.cpp:1264
5 	XUL	NS_ProcessNextEvent(nsIThread*, bool)	xpcom/threads/nsThreadUtils.cpp:389
6 	XUL	nsThread::Shutdown()	xpcom/threads/nsThread.cpp:1015
7 	XUL	mozilla::net::nsSocketTransportService::ShutdownThread()	netwerk/base/nsSocketTransportService2.cpp:612
8 	XUL	mozilla::net::nsIOService::SetOffline(bool)	netwerk/base/nsIOService.cpp:1117
9 	XUL	mozilla::net::nsIOService::Observe(nsISupports*, char const*, char16_t const*)	netwerk/base/nsIOService.cpp:1426
10 	XUL	non-virtual thunk to mozilla::net::nsIOService::Observe(nsISupports*, char const*, char16_t const*)	netwerk/base/nsIOService.cpp:1411
Component: Untriaged → General
Flags: needinfo?(thomas)
Whiteboard: [closeme 2017-04-11 dupme]
(Reporter)

Comment 4

8 months ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #3)
> Nothing on crash stats after buildid 20170305030206 nightly build. Perhaps
> bug 791645 helped?
> 
> Thomasy, you are still running that old build and crashed recently
> bp-127dac56-1dfc-4814-8fb3-4a07a2170324 below - I'm curious why you are
> still running that build?  Do you still crash if you update to a newer
> version of THunderbird daily?  (I doubt KB3178674  has anything to do with
> this)
> 
>  0 	XUL	nsImapProtocol::SetupWithUrlCallback(nsIProxyInfo*)
> /builds/slave/tb-c-cen-m64-ntly-000000000000/build/mailnews/imap/src/
> nsImapProtocol.cpp:894
> 1 	XUL	non-virtual thunk to nsImapProtocol::OnProxyAvailable(nsICancelable*,
> nsIChannel*, nsIProxyInfo*, nsresult)
> /builds/slave/tb-c-cen-m64-ntly-000000000000/build/mailnews/imap/src/
> nsImapProtocol.cpp:852
> 2 	XUL	mozilla::net::nsAsyncResolveRequest::DoCallback()
> netwerk/base/nsProtocolProxyService.cpp:280
> 3 	XUL	mozilla::net::nsAsyncResolveRequest::Run()
> netwerk/base/nsProtocolProxyService.cpp:156
> 4 	XUL	nsThread::ProcessNextEvent(bool, bool*)
> xpcom/threads/nsThread.cpp:1264
> 5 	XUL	NS_ProcessNextEvent(nsIThread*, bool)
> xpcom/threads/nsThreadUtils.cpp:389
> 6 	XUL	nsThread::Shutdown()	xpcom/threads/nsThread.cpp:1015
> 7 	XUL	mozilla::net::nsSocketTransportService::ShutdownThread()
> netwerk/base/nsSocketTransportService2.cpp:612
> 8 	XUL	mozilla::net::nsIOService::SetOffline(bool)
> netwerk/base/nsIOService.cpp:1117
> 9 	XUL	mozilla::net::nsIOService::Observe(nsISupports*, char const*,
> char16_t const*)	netwerk/base/nsIOService.cpp:1426
> 10 	XUL	non-virtual thunk to
> mozilla::net::nsIOService::Observe(nsISupports*, char const*, char16_t
> const*)	netwerk/base/nsIOService.cpp:1411

I am using comm-central-l10n zh-TW version. It seems there is no newer build recently. Maybe is another bug of build system.

http://archive.mozilla.org/pub/thunderbird/nightly/2017/04/2017-04-01-03-02-03-comm-central-l10n/
http://archive.mozilla.org/pub/thunderbird/nightly/latest-comm-central-l10n/

But the version I use is not crash any more (zh-TW 2017-03-05).
Flags: needinfo?(thomas)
Yes, sadly due to bug 1345422 there haven't been any localised builds since 2017-03-05. You'd have to try an en-US version from: http://archive.mozilla.org/pub/thunderbird/nightly/latest-comm-central/
Localised comm-central builds are back, we're working on Aurora/Earlybird:
http://ftp.mozilla.org/pub/thunderbird/nightly/2017/04/2017-04-05-03-02-11-comm-central-l10n/
(Reporter)

Comment 7

8 months ago
(In reply to Jorg K (GMT+2) from comment #6)
> Localised comm-central builds are back, we're working on Aurora/Earlybird:
> http://ftp.mozilla.org/pub/thunderbird/nightly/2017/04/2017-04-05-03-02-11-
> comm-central-l10n/

The localized comm-central build work fine. We may close this bug.

Comment 8

7 months ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2017-04-11 dupme]
You need to log in before you can comment on or make changes to this bug.