overflow style on div does not work

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Maksim Likharev, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

I have overflow on div and it does not work.

go www.likharev.com
toolbar up there should not be scrolled out.

Reproducible: Always
Steps to Reproduce:
1. see description
2.
3.

Comment 1

16 years ago
I'm not sure what you're seeing or what you think you should be seeing, but I
see no scrollbars (regardless of window size) with linux build 20020401.  with
0.9.9, I can get a vertical scrollbar if the window height is within a certain
range.  Is that what you're seeing?
(Reporter)

Comment 2

16 years ago
Created attachment 77187 [details]
IE 6.0 layout and Mozilla 0.9.9 layout

mozilla 0.9.9 layout
(Reporter)

Comment 3

16 years ago
Created attachment 77189 [details]
IE 6.0 layout
(Reporter)

Comment 4

16 years ago
Hi,
Here are two browsers (see attachment), 
IE 6.0 and Mozilla 0.9.9
I have overflow on body=hide and overflow on div=auto,
I am not saying that IE 6.0 works correct, but that what I expect.


Best Regards,
Maksim

(Reporter)

Comment 5

16 years ago
Created attachment 77195 [details]
some test suit that may help
(Reporter)

Comment 6

16 years ago
Ok,
I've posted some html files, that may help resolve that problem.
so, you could see 2 problems:
1. Overflow,
    click on 'go next page'
    on new page you should see, banner ( a frame ), toolbar ( a table ) and 
    text inside a div.
    javascript help positioning div, so scrollbars should be on the div
    not body, moreover body has style 'overflow: hidden', that should not 
    be any scroll bars at all
2. Navigation
    when you cilck on second page link 'link back' it will scroll first
    and only after second click it will nawigate back.

Regards,
Maksim
    

Comment 7

16 years ago
Created attachment 77213 [details]
screenshot: mozilla 20020401
(Reporter)

Comment 8

16 years ago
Ok, look like I figured it out, 
'document.body.clientHeight' in IE, 
'window.innerWidth' in Mozilla,
in Mozila 'document.body.clientHeight' just returns 0,
guys, I understand that you are supporting W3 standards, but 
only one way Mozilla could fight IE is be as compatible with IE as it possible,
little thing here, little thing there and it’s become it almost impossible to 
support Mozilla at all. Not because I am Mr. Nasty, but that’s how 99% Web 
developers feeling.
I am not saying that you should do this; everything is up to you.

Comment 9

16 years ago
Changing QA contact
QA Contact: petersen → amar
(Reporter)

Comment 10

16 years ago
On build 2002040203, no more scroll bars on BODY with overflow = hidden,
that has been fixed.
But still, 
document.body.clientHeight and document.body.clientWidth returns 0, but 
as I understand that should be equivalent of 
window.innerWidth and window.innerHeight.
So, should I file new bug on that, look like that's IE compatibility issue?

Regards,

Comment 11

16 years ago
the clientwidth/height issue seems to be a known issue with setting overflow to
hidden, rather than not supporting it because of IE/W3 issues.  see bug 62536.

is this WORKSFORME for the scrollbar issue?
(Reporter)

Comment 12

16 years ago
Yes indeed clientWidth/Height it is a known bug, 
#62536 includes this issue.

As for overflow: hidden, that WORKSFORME,
so lets close it or mark as a duplicate.

Regards
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.