pk12util crashes after importing P12 in to token

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: magenex, Assigned: rrelyea)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I am using RC1 of NSS 3.4 binaries (WINNT4.0_DBG.OBJ) on Windows 2000. The
pk12util crashes after successfully importing the P12 file into the smart card.
The smart card is a Schlumberger Cryptoflex 8K. I am using the PKCS11 drivers
that come with the Cyberflex Access 4.1 SDK. I even got the same problem with
the GemSAFE smart cards using the GemSAFE PKCS11 drivers.

The above problem doesn't occur on the NSS 3.3.2 binaries (WINNT4.0_DBG.OBJ)
using the same PC and smart cards.

The following is the command that was passed to pk12util:
pk12util -d .\ -i ptaclient.p12 -h "Cryptoflex 8k"

Comment 1

17 years ago
*** Bug 134811 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Priority: -- → P1
Target Milestone: --- → 3.4.1

Comment 2

17 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee

Comment 3

17 years ago
Assigned the bug to Ian.  Target NSS 3.5, priority P2.
Assignee: wtc → ian.mcgreer
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P1 → P2
Target Milestone: 3.4.1 → 3.5

Updated

16 years ago
Target Milestone: 3.5 → 3.6

Comment 4

16 years ago
Assigned the bug to Bob.
Assignee: ian.mcgreer → relyea
Target Milestone: 3.6 → 3.7

Comment 5

16 years ago
Moved to target milestone 3.8 because the original
NSS 3.7 release has been renamed 3.8.
Target Milestone: 3.7 → 3.8
Remove target milestone of 3.8, since these bugs didn't get into that release.
Target Milestone: 3.8 → ---
Odds are good that:
a) this problem was originally related to the use of non-ASCII characters 
in the PKCS12 file's "friendly name", which NSS turns into the "nickname",
and 
b) this behavior is different now than it was 2 years ago when it was reported.

Odds are also very good that NO PROGRESS will be made on this unless and 
until the NSS developers can reproduce it, or at least can determine the cause
from something like a stack trace.  

Sage Salvatore, if you can reproduce this problem with the debug version of 
NSS 3.9, please please let us know here.  Thanks.
We cannot reproduce this, and the reporter has not added a reproducible
test case in over 6 months.  So, marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.