Closed Bug 1348195 Opened 3 years ago Closed 3 years ago

Investigate if nsRange has same bug as bug 1347809

Categories

(Core :: DOM: Editor, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1347809 +++

nsRange calls Selection::NotifySelectionListeners(). At this time, it doesn't change *its* mCalledByJS to false. Therefore, if it's internal methods are called during a call of Selection::NotifySelectionListeners(), it treats the call as called by JS.
Comment on attachment 8848450 [details]
Bug 1348195 nsRange should set mCalledByJS to false before calling Selection::NotifySelectionListners() because non-*JS() methods may be called during a call of it

https://reviewboard.mozilla.org/r/121368/#review123434
Attachment #8848450 - Flags: review?(bugs) → review+
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/b2f781a18186
nsRange should set mCalledByJS to false before calling Selection::NotifySelectionListners() because non-*JS() methods may be called during a call of it r=smaug
https://hg.mozilla.org/mozilla-central/rev/b2f781a18186
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.