[DOGFOOD] Using Backspace key at the beginning of line causes Apprunner crashes

VERIFIED FIXED

Status

()

Core
Editor
P1
critical
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you delete the characters by using Backspace key, Apprunner will crash at the beginnig of line.

Steps of reproduce
1. Launch Apprunner
2. Select menu Task|Editor to open the Editor
3. Move the cursor a the beginning of the first line (before "H")
4. Hit the Backspace once

Apprunner crashes.

Tested 9-09-99 Win32 build.

Comment 1

19 years ago
with or without IME enabled?

Updated

19 years ago
Assignee: buster → jfrancis
Severity: major → critical
Priority: P3 → P1
Summary: Using Backspace key at the beginning of line causes Apprunner crashes → [DOGFOOD] Using Backspace key at the beginning of line causes Apprunner crashes

Comment 2

19 years ago
assigned to joe.  IME is irrelevant for this bug.  high priority since it's a
crasher, and will destabilize the browser as well as the editor.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
accepting - trying to fix this right now...
(Assignee)

Comment 4

19 years ago
fixed - waiting for tree to open...
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
ok - fix checked in

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
verified in 9/14 build.
You need to log in before you can comment on or make changes to this bug.