Bug 134716/onClick in complex table does not work

RESOLVED DUPLICATE of bug 134716

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 134716
16 years ago
16 years ago

People

(Reporter: Fulco Bohle, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031008

I have attached a better example to show the bug (134716).

The example consists of an outer table and an inner table in the left column.
The left column has a rowspan of 2 the right column has two separate rows. The
problem is with the empty cells in the inner table (the agenda) that are next to
the lower row in the right column.(see example). If you click on them nothing
happens.

the problem lies within rowspan=2 I guess.


 

Reproducible: Always
Steps to Reproduce:
1.follow the remarks in the example
2.
3.

Actual Results:  nothing

Expected Results:  respond to the click

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<html>
<head>
<meta NAME="AUTHOR" CONTENT="Fulco Bohle">
</head>
<SCRIPT LANGUAGE="JavaScript">

function test_onClick( datum, tijd)
	{
	window.confirm( "onClick datum "+datum+" tijd "+tijd);
	}

</SCRIPT>

<body>

<table WIDTH="100%" BORDER="1"><td ROWSPAN="2">

<table BORDER="1" RULES="ALL" WIDTH="100%">
<tr><th COLSPAN="2">time</th><th WIDTH="90%">appointment</th></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">8</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '08:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '08:30');">(first click here to get a
popup and next click on the empty cell below)</td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">9</td><TD>00</td>

<td onClick="test_onClick( '2002-4-16', '09:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '09:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">10</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '10:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '10:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">11</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '11:00');"></td></tr>
<tr><TD>30</td>

<td onClick="test_onClick( '2002-4-16', '11:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">12</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '12:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '12:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">13</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '13:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '13:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">14</td><TD>00</td>

<td onClick="test_onClick( '2002-4-16', '14:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '14:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">15</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '15:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '15:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">16</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '16:00');"></td></tr>
<tr><TD>30</td>

<td onClick="test_onClick( '2002-4-16', '16:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">17</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '17:00');">(next click here and after
that click on the empty cell below)</td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '17:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">18</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '18:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '18:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">19</td><TD>00</td>

<td onClick="test_onClick( '2002-4-16', '19:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '19:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">20</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '20:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '20:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">21</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '21:00');"></td></tr>
<tr><TD>30</td>

<td onClick="test_onClick( '2002-4-16', '21:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">22</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '22:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '22:30');"></td></tr>
<tr><TD VALIGN="TOP" ROWSPAN="2">23</td><TD>00</td>
<td onClick="test_onClick( '2002-4-16', '23:00');"></td></tr>
<tr><TD>30</td>
<td onClick="test_onClick( '2002-4-16', '23:30');"></td></tr>
</table>
</td>
<td WIDTH="280" HEIGHT="160">if you click next to this cell a popup appears also
with empty cells
</td>
<TR>
<TD> if you click next to this cell no popup appears if you click on empty cells
</td>
</table>

</body>
</html>

Comment 1

16 years ago
Thank you, but we like to have everything in one bugreport.

To attach new testcases to that bug do the following:
  Goto http://bugzilla.mozilla.org/show_bug.cgi?id=134716
  Click on 'Create a new attachment'

You can also provide comments in the 'Additional Comments' section.


*** This bug has been marked as a duplicate of 134716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
It is not clear if this bug is received ?

Fulco
Status: RESOLVED → UNCONFIRMED
Depends on: 134716
Resolution: DUPLICATE → ---
Fulco Bohle, how is this bug different from bug 134716 exactly?
(Reporter)

Comment 4

16 years ago
This is the same bug, I only did some extra research to isolate the problem. My first guess was not 
quite accurate. The example in bug  134822 wil show you exactly what is wrong. So forget 134716 and 
concentrate on 134822. Both the Windows and Linux versions have this problem. At the bottom of 
this message is a copy of the example.

I apologize for the confusion, this is the first time I 
use bugzilla.

Fulco

(Nice browser)
This example has already been attached to bug 134716

*** This bug has been marked as a duplicate of 132716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
No longer depends on: 134716
Resolution: --- → DUPLICATE

Comment 6

16 years ago
spam spam spam
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

16 years ago
correcting bug#

Fulco: The other bug is already marked NEW and under investigation.

*** This bug has been marked as a duplicate of 134716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

16 years ago
Note that the height parameter in the example affects the area that does not respond: see the line 
that contains

<td WIDTH="280" HEIGHT="160">if you click 

and modify the height to lets 
say 260

Fulco
You need to log in before you can comment on or make changes to this bug.