Closed Bug 1348290 Opened 3 years ago Closed 3 years ago

Pause contextual menu option is grayed out after cancelling and resuming a download

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox52 --- wontfix
firefox53 --- affected
firefox54 --- affected
firefox55 --- affected
firefox56 --- affected
firefox57 --- affected
firefox58 --- affected

People

(Reporter: JuliaC, Unassigned)

References

Details

[Affected versions]:
- 55.0a1 (2017-03-17) 
- 54.0a2 (2017-03-17)
- 53.0b3 build1 (20170316045436)
- 52.0 build2 (20170302120751)

[Affected platforms]:
- Windows 7 x64 
- Mac OS X 10.10
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Launch Firefox
2. Start downloading a large file (e.g. https://www.ubuntu.com/download/desktop)
3. Click the downloads button from the toolbar in order to open the Downloads panel
4. Click the Cancel button next to the download progress
5. Click the Retry button next to the download progress
6. Pause the current download (inspect the Pause context menu option)

[Expected result]:
- The user is able to properly pause the current download, even if it was previously canceled

[Actual result]:
- The Pause context menu option is grayed out

[Regression range]:
- This issue is not a recent regression as it is reproducible all the way back to 46.0a1 (2016-01-01)
Mass wontfix for bugs affecting firefox 52.
This is likely an issue with the specific server implementation, because normally downloads can be paused and resumed multiple times.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
I reopen this bug because I have seen the issue is still there. Using the following link for downloading multiple files with different sizes: https://www.thinkbroadband.com/download. Start downloading then pause it, after that resume it, try to pause it again, you will see the "Pause" item from context menu is grayed out.
Affected Firefox versions: 56.0.1, 57.0b8 and latest nightly 58.0a1 (2017.10.12), all platforms: Windows 8.1 x64, Ubuntu 14.04 x64, Mac 10.11.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
This works for me with the links from comment 3, so the issue is likely related to the proxy or firewall software on the local network intercepting requests and making them not resumable in some cases.

Unfortunately there is nothing we can do, so there is no point in keeping the bug open.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.