Problem FF v52 with JIRA Accounts

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
9 months ago
3 months ago

People

(Reporter: robert.mazur@silvermedia.pl, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 months ago
Created attachment 8848516 [details]
FF55_JIRA_error.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

Steps to reproduce:

Where is a problem in newest FF 52.0 with JIRA (Atlassian) -> Account form. It not allow to edit Account field.
Resetting FF to fabric settings not helps.
Reinstalling FF to 51.0 restores ability to edit Account field in JIRA.
This Account field is editable when mouse is over it.
In FF 52.0 there is problem also with displaying full name of Account – see attachment.

I repeated this on another computer and there was identical maintenance with FF 52.0 and JIRA Accounts.





Expected results:

FF v52 should allow edit Account field like FF v51
Robert, I could not reproduce the issue you are describing, actually, I was not able to get to Account form you mentioned. If possible, could you please provide the complete url address you are using, in order to try to create on my end the Account form. Also, please let us know what Jira version are you using?
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 2

9 months ago
We are using:
Atlassian JIRA Project Management Software (v7.3.1#73012-sha1:68837e3)
System Plugin: Tempo Accounts 3.0.6 
System Plugin: Tempo Core 4.1.2 
Tempo Timesheet 8.2.3

Path to reproduce the issue:
Menu [Tempo]
choose [Accounts] -> [more]
choose one of defined Account
chose [Time Tracking]
chose [Timesheet] -> [Report]

URL for example (you should change accountId=87 to proper):
https://jira.silvermedia.pl/secure/TempoAccountBoard!report.jspa?v=1&periodType=BILLING&periodView=PERIOD&period=0317&accountId=87

In attachment (FF_JIRA_problem.zip) you can find this JIRA page saved by FF 51.0 and 52.0.1.
You can see deferences in column "Account" - FF52 didn't read (and display) this column correctly.
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 3

9 months ago
Created attachment 8850430 [details]
Deferences between FF 51.0 and 52.0.1
Created attachment 8857014 [details]
screencast1348308.avi

Hi Robert,
I could not reproduce this on my Jira Account.

But, I played a little with the two attachments you sent(for FF 52.0.1 and FF 51.0) and with the attachment for FF 51.0, I was not able to update all the elements from column Account only the ones with an invalid date for the date column. On the file with FF 52, there is no line with an invalid date so none of them is editable. Could you please try again on your side?
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 5

8 months ago
Hi,
It's true. For FF51 these elements are enabled but not all - only when mouse is move over it.
In FF52 moving mouse over these elements not loading it.
I think this is source of the problem - FF52 not loading that kind of component on mouse over.
FF51 works fine.
Flags: needinfo?(robert.mazur)

Comment 6

8 months ago
On both versions of your files, editable are only those fields with tempo-inline-edit class and with visible image of calendar. Adding this class makes fields editable. Jira gives you different output for different browsers. Doesn't look like a Firefox bug.
Robert, I opened your 51 attachment on Firefox FF 52.0.1, and the elements with the Invalid date are editable here too. So, the editable fields can be edited on FF 51.0 and also on FF 52.0.1. Please try on your side to open the attachment for 51, but on Firefox FF 52.0.1.
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 8

8 months ago
Krzysztof - you're close the point. "Jira gives me different output for FF51 and FF52" or "FF52 decodes source page in different way than FF51 and other browsers". FF51 don't have problem with showing this editable fields while FF52 can't show it properly.

Brindusa - opening that attachment FF51 on FF52 doesn't make sense because this page is saved form FF51 where everything is alright (as I can imagine "source of page is converted via browser").
There's something wrong with FF52 - it can't show editable fields.

I checked it few minutes ago again on third computer - it's the same (FF 51.0.1 works fine).
First of all FF52 don't show properly Account - there is "000000" (it's key!) instead "000000 - Koszty ogólnofirmowe (administracyjne)" (it's value!).
Action OnMouseMove which shows editable fields is only possible when Account value is shown properly.
Flags: needinfo?(robert.mazur)
Hi Robert, could you verify if this issue is reproducible on FF 53? On my Jira account, I could not reproduce this issue on any of Firefox versions(51, 52 or 53).
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 10

8 months ago
Yes. FF 53.0 still has the problem. I checked yesterday.
Field "Account" is not decoded on its value and it's impossible to edit it.
Flags: needinfo?(robert.mazur)
Robert, I tried again on latest release version 54.0.1, but still, I could not reproduce this bug.

Could you please verify if this issue is reproducible on latest Firefox 54.0.1.
Flags: needinfo?(robert.mazur)
(Reporter)

Comment 12

5 months ago
Hi,
we reconfigured JIRA in different way and now we haven't got this page so problem is workarounded.
Thanks for you try.
Flags: needinfo?(robert.mazur)
Sorry for late response. I still cannot reproduce this on latest release 55.0.3. Based on this and on the previous comment I will mark this resolved Worksforme.

If someone still can reproduce this issue, please reopen the bug and provide more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.