firefox modal dialog does not echo typed characters to screen with gfx.xrender.enabled:true

RESOLVED WONTFIX

Status

()

Core
Graphics: Text
RESOLVED WONTFIX
7 months ago
6 months ago

People

(Reporter: boardman_malibu@yahoo.com, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170310202202

Steps to reproduce:

When modal "password required" pops up to unlock the password vault, or modifying a value in "about:config"


Actual results:

Typing a character produces no change in the display, like the dialog had no focus, however pressing ENTER shows that the characters were accepted.


Expected results:

Pressing a character key should cause a character to be displayed in the dialog text box.

Comment 1

7 months ago
The descriptions is read-only, so it will not be entered.

Or, are you have problems while input content into textbox of modal dialog?
Flags: needinfo?(boardman_malibu)
(Reporter)

Comment 2

7 months ago
First of all, let me report the correct user agent:

User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:52.0) Gecko/20100101 Firefox/52.0

Running on Linux Mint 18.1, fresh install.

This problem only happens with firefox modals. Web page text boxes have no issue.

The modal dialogs seem to have no focus even when clicked on (no flashing caret). In the case of the password vault master password, clicking on X doesn't seem to kill the dialog as it keeps coming back. When I type in the correct password, it stays gone and form autofill seems to work.  At no time while typing the password did I see any characters (dots) being added to the text box.

When I attempt to modify a value in "about:config" nothing changes in the dialog as I type, but I do see that the changed happened after hitting ENTER.

Comment 3

7 months ago
When the "nothing changes in the dialog as I type", the text can be selected or not? If yes, to graphics problems, if not, to widget or else.
(Reporter)

Comment 4

7 months ago
The problem was fixed when I set "gfx.xrender.enabled" back to false (the default).  Although setting it to true eliminated diagonal tearing when I scrolled, it's not worth the trouble.

Updated

7 months ago
Component: Untriaged → Graphics: Text
Flags: needinfo?(boardman_malibu)
Product: Firefox → Core
I don't believe we're supporting this pref, so I'm marking this WONTFIX.
cc'ing milan for confirmation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(milan)
Resolution: --- → WONTFIX
Summary: firefox modal dialog does not echo typed characters to screen → firefox modal dialog does not echo typed characters to screen with gfx.xrender.enabled:true
Whiteboard: gfx-noted
It isn't supported, although we may take patches.  So, in that way, not really fully "wontfix" in the sense that we would block a valid solution, but probably best to leave that way until somebody shows up to work on it.
Flags: needinfo?(milan)
You need to log in before you can comment on or make changes to this bug.