View Source STILL doesn't work for form POSTs

VERIFIED INVALID

Status

Core Graveyard
View Source
--
major
VERIFIED INVALID
16 years ago
8 years ago

People

(Reporter: Adam Batkin, Assigned: Doron Rosenberg (IBM))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I am running Build 2002040108 which supposedly should have whatever fixes were
implemented by Bugs 55583 and 40867 and many others...

View Source STILL does not show the correct source...BUT at least it doesn't go
out across the network and re-post the form anymore...On the other hand, my
milestone .99 build didn't do that either. In fact, both builds do the exact
same thing:
They return the source for the URL that I originally accessed the page with. Let
me explain:
http://www.batkin.net/~abatkin/cgi-bin/test.pl
Is a very simple script. It dumps any form variables, prints out a POST form
(that POSTs to itself) and prints out the UNIX time.
If I simply open that URL, everything is fine. I can view the source, etc...
If I then fill out the form and submit it, the resulting URL is EXACTLY the same
as before (since it is POSTing to itself) but when I view the source to the new,
submitted page, I get the original source from when I first opened the URL. I
know this because the server log doesn't show any extra accesses, and the UNIX
timestamp is the same as the first access.

File-Save Page As actually works correctlyI and saves the correct version (well,
kinda, it actually mutilates the HTML but I really can't complain since the
script doesn't return valid HTML at all)

Comment 1

16 years ago
Fix has been checked-in at 13:20 04-01
Thus, you must wait for the build from 04-02.

Resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
vrfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.