nsILoadContext::GetOriginAttributes is too slow

RESOLVED DUPLICATE of bug 1316683

Status

()

Core
General
RESOLVED DUPLICATE of bug 1316683
a year ago
11 months ago

People

(Reporter: smaug, Unassigned)

Tracking

36 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
http://searchfox.org/mozilla-central/rev/c2a60adfc7b16761cbbfcefa2093fa402ba1aa69/docshell/base/LoadContext.cpp#16 does some crazy JS stuff, when it should just use mOriginAttributes when nsILoadContext is C++ implemented.
(Reporter)

Updated

a year ago
Blocks: 1348460
(Reporter)

Comment 1

a year ago
er, not perhaps mOriginAttributes, but whatever native method there is to access OA.
(Reporter)

Comment 2

a year ago
Yoshi, do you think you could take a look at this? Somehow make the method fast in the common case when nsILoadContext is C++ implemented.
Flags: needinfo?(allstars.chh)

Comment 3

11 months ago
I started to write a patch for this in bug 1316683 before I saw this.  I think this was originally done to avoid having C++ callers go through JSAPI, so maybe that was the thinking behind the implementation, but the implementation certainly doesn't make sense in retrospect.  :-)

I think we can make this a dupe?

Updated

11 months ago
No longer blocks: 1348460

Comment 4

11 months ago
Now this function won't even exist!
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1316683
Flags: needinfo?(allstars.chh)
You need to log in before you can comment on or make changes to this bug.