Closed Bug 1348476 Opened 3 years ago Closed Last year

Crash in shutdownhang | kernelbase.dll@0xcae48

Categories

(Core :: General, defect, critical)

53 Branch
x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox52 --- wontfix
firefox53 - affected
firefox54 --- affected
firefox55 --- affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-9df6258f-dd13-4bb0-9740-4cbb82170318.
=============================================================
Neta54.0b4 : bp-9df6258f-dd13-4bb0-9740-4cbb82170318
Aurora 54.0a2 : bp-1499ecb2-6bd8-478f-ba3f-944382170318
Night;y55.0a1 : bp-d169150f-1a85-4566-9fce-b85522170318

When I test Bug 1348447, Firefox crashes at shutdown.
The crash seems do not happen with e10s enabled.


Reproducible: always

Steps To Reproduce:
1. Maximize browser
2. Open http://dev-solutions.s3.amazonaws.com/arthur/viewer-kit-FF-bug/dist/index.html
3. Click on image (large one)
4. Repeatedly click on the "+" button in the right bottom corner
5. And then, Repeatedly click on the "-" button in the right bottom corner
6. Repeat Step 4 and 5 for another image
7. Close the browser

Actual Results:
After for several minutes, crash reporter pops up.

Expected Results:
No Crash.
typo
s/Neta54.0b4/Beta53.0b4/
[Tracking Requested - why for this release]: This crash is pretty high in 52 (#4 overall in browser), and it is happening in 53 as well. We should track it for investigation before we ship 53.
there seem to be missing symbols after the last win10 patch day...
Crash Signature: [@ shutdownhang | kernelbase.dll@0xcae48] → [@ shutdownhang | kernelbase.dll@0xcae48] [@ shutdownhang | _PR_MD_WAIT_CV | _PR_WaitCondVar | mozilla::CondVar::Wait | nsEventQueue::GetEvent | nsThread::ProcessNextEvent | NS_ProcessNextEvent | nsThread::Shutdown | nsThreadManager::Shutdown]
ni on ted to see about the missing symbols noted in Comment 3.
Flags: needinfo?(ted)
The Microsoft symbol fetching job hadn't been running, so I ran it manually yesterday and it backfilled a bunch of symbols. I forced https://crash-stats.mozilla.com/report/index/9df6258f-dd13-4bb0-9740-4cbb82170318 to reprocess, so you should be able to reload it in a bit and it will have symbols (reprocessing is fast, but there's a cache in front of the webapp with ~1 hour expiry).
Flags: needinfo?(ted)
Reloading that crash shows it having the same stack as philipp added in comment 3, so at least that's fixed.
Found a similar issue logged: Bug 1312546. Maybe the two of them are related.
Component: Untriaged → General
See Also: → 1312546
Too late for firefox 52, mass-wontfix.
This looks to be all shutdown hangs for Thunderbird.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.