digitalart.org - alert-window pops up when hovering over link

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: bengtd, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

URL: http://digitalart.org/artwork/new.php
well, i'm not sure wether this is a problem with mozilla, or the page... 
however, when hovering over a link in the 'title'-column, a small 100x100px
large thumbnail should appear (it does so in IE). Instead, a 'alert'-window
popps up, saying: <img src=http://digitalart.org/artwork/art-bin/xxxx.jpg
width=100 height=100> (xxxx varies, depending on link) and a 'OK'-button.
No problem so far... I can hit Enter to close the alert-window and click on the
link (only works when i don't move the mousecursor off the link).
But when I try this with a link at the bottom of the page, after hitting Enter
to close the alertpopup and clicking the mousebutton, Mozilla ignores the click
and jumps up to the top of the page...

Reproducible: Always
Steps to Reproduce:
1. open the page (URL: http://digitalart.org/artwork/new.php)
2. scroll down the page
3. move mousecursor over one of the links in the title column (i.e. row 35)
4. hit Enter to close the alert-window (alert-window: see Descrtiption)
5. DON'T move the mousecursor off the link!!
6. leftclick on link (or alternativly rightclick to open link in new tab/window)

Actual Results:
step 3: Mozilla shows Alert-window (see Description)
step 6: Mozilla jumps up to the top of the page and ignores the click on the link.

Expected Results:
step 3: show 100x100 px large preview-thumbnail
step 6: leftclick: Mozilla should open the link in current tab/window
rightclick: Mozilla should open context-menu and offer 'open in new tab/window'

this seems to be the part of the HTML-code responsible for misbehavior:
...
<tr>
<td bgcolor=#F8F8F8 align=center valign=center class=small-text>Apr 01, 2002</td>
<td bgcolor=#F8F8F8><img src=http://digitalart.org/images/bullet_square.gif
width=10 height=9><a href=http://digitalart.org/artwork/artwork.php?ID=7304
onMouseOver="popup('<img src=http://digitalart.org/artwork/art-bin/7304t.jpg
width=100 height=100>','#000000')"; onMouseOut="kill()">nature death2</a></td>
<td bgcolor=#F8F8F8><a href=http://digitalart.org/artists/artists.php?ID=1966
style='font-weight:400'>Angel Estevez</a></td>
<td bgcolor=#F8F8F8><a href=http://digitalart.org/artwork/categories.php?ID=8
style='font-weight:400'>Miscellaneous</a></td>
</tr>
...

Comment 1

17 years ago
Confirmed
2002040303/WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: alert-window popps up when hovering over link under 'title' (bold) → digitalart.org - alert-window pops up when hovering over link

Comment 2

16 years ago
1 year later... DigitalArt has rewritten their popup scripts, and includes a
code path for NS6. Works for me in Moz 2003032808.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.