The Stub installer is installing 32 bit Firefox on 64 bit Windows.

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
VERIFIED FIXED
11 months ago
8 months ago

People

(Reporter: Caspy7, Assigned: pmac)

Tracking

Production

Firefox Tracking Flags

(firefox54 wontfix, firefox55 verified, firefox56 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
I've seen multiple reports from users and now tested myself and another developer.

0) Be on 64 bit Windows
1) Go to https://www.mozilla.org/en-US/firefox/new/ 
2) Click on "Firefox for Other Platforms and Languages" 
3) Click "Windows 64-bit"
4) Download/install/run installer

Expect to install 64 bit version of Firefox.

Actually install 32 bit version of Firefox (as verified in the About dialog).

Seems like it's a bug in the installer, but in the mean time we also need to fix the page offering the links.

Updated

11 months ago
Component: Other → Installer
Product: Websites → Firefox
When I tried to reproduce this (using Chrome on 64bit Windows 10) at 1) I got sent to 
  https://www.mozilla.org/en-US/firefox/new/?f=102
which is from a funnelcake test (bug 1332726). That would provide a 32 bit installer because the test only has those. ni cmore for this.
Flags: needinfo?(chrismore.bugzilla)
At 3, the link I get is https://download.mozilla.org/?product=firefox-stub&os=win64&lang=en-US&attribution_code=c291cmNlPXd3dy5tb3ppbGxhLm9yZyZtZWRpdW09cmVmZXJyYWwmY2FtcGFpZ249KG5vdCBzZXQpJmNvbnRlbnQ9KG5vdCBzZXQpJnRpbWVzdGFtcD0xNDg5ODk1NDUy&attribution_sig=73d16e73f441ba4e9611a98920c1bda740e8c52c5fc069bf312e75ed5cccec55. In bug 797208 the stub installer gets smart and will download the 32 or 64 bit full installer depending on the OS it is running on. However it only does this for Firefox 53, and we have 52.0.1 on release right now. ni pmac for this, it does look like a regression from bug 1344220.
Flags: needinfo?(pmac)

Comment 3

11 months ago
The link described in comment 0 should not currently be directing to stub installers at all, because the stub for release 52 cannot download 64-bit builds. That option was added in 53, and even then it isn't set by default until 55. The link should be to a full installer.

(not sure if this is the right component, but at least it's the right product)
Component: Installer → Pages & Content
Product: Firefox → www.mozilla.org
Version: unspecified → Production

Updated

11 months ago
Duplicate of this bug: 1348817
Working on this now. Which channel(s) should get a stub installer for 64bit windows? Only Nightly?
Flags: needinfo?(pmac)

Comment 6

11 months ago
Right now, yes. The current plan is to allow that to ride the 55 train.
Created attachment 8849645 [details] [review]
Link to Github pull-request: https://github.com/mozilla/bedrock/pull/4729

This is the fix. It's already been given an r+ by :agibson. As soon as tests pass in CI I'll merge it and start the production push.
Assignee: nobody → pmac

Comment 8

11 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ea657fcb18c74f3012bf0d7dd71267b8f4a6802f
Fix bug 1348610: Win64 stub installer only for Nightly

Stub installer for win64 is scheduled to ride the Fx 55 train,
we should not enable it for more channels (aurora, beta, release)
until we're told that smart switching has been enabled in the stub.

https://github.com/mozilla/bedrock/commit/436d87f986412fc0d23393d40b730e12fb10e138
Merge pull request #4729 from pmac/remove-win64-stub-installer-1348610

Fix bug 1348610: Win64 stub installer only for Nightly

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Fixed in prod. Update here if you see any instances more instances of the issue.
Status: RESOLVED → VERIFIED

Comment 10

11 months ago
Hi everyone.

Sorry being late to the game. Thee was also an email thread related to this.

Should I change the targeting conditions for the funnelcake to only target Win32 or exclude Win64 or will the fix that :pmac pushed resolve this directly? 

Please let me know.
Flags: needinfo?(chrismore.bugzilla)
I believe our fix will fix it since win64 no longer gets a stub-installer link at all. Does that sound right to you Chris?

Comment 12

11 months ago
(In reply to Paul [:pmac] McLanahan from comment #11)
> I believe our fix will fix it since win64 no longer gets a stub-installer
> link at all. Does that sound right to you Chris?

Will it work like this?

English Win64 visitor go to /firefox/new/, they will get redirected to ?f=101 or ?f102 from Optimizely, but they ?f= funnelcake helper won't tell bouncer to give them a stub installer and they will get a normal win64 full installer instead. Is that how it will work for the win64 audience if they get pulled into the funnelcake redirect?
Currently the only way to get a 64bit download for release from the /new/ page is to click on the "Firefox for other platforms and languages". So if you go to:

https://www.mozilla.org/en-US/firefox/new/?f=101

The link for win64 in the modal is unaffected.
(In reply to Chris More [:cmore] from comment #10)
> Should I change the targeting conditions for the funnelcake to only target
> Win32 or exclude Win64 or will the fix that :pmac pushed resolve this
> directly? 

About 74% [1] of Firefox users are running Win64 OS, so excluding them will reduce your Funnelcake's eligible user population, if that matters. But if a user that asks for 64-bit Firefox 52 and gets 32-bit will be upset.

[1] https://metrics.mozilla.com/firefox-hardware-report/#goto-os-and-architecture
Does this 64-bit issue on still exist in the installer?
Never mind, 55 is the current target as said earlier.
status-firefox54: --- → wontfix
status-firefox55: --- → verified
status-firefox56: --- → verified
You need to log in before you can comment on or make changes to this bug.