AMO page signin link not working

UNCONFIRMED
Assigned to

Status

UNCONFIRMED
2 years ago
3 months ago

People

(Reporter: relay12, Assigned: stomlinson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20131112160018

Steps to reproduce:

On page https://addons.mozilla.org/en-US/firefox/ choose login link


Actual results:

Page https://oauth.accounts.firefox.com/v1/authorization?action=signin&scope=profile... fails to load


Expected results:

Prompted to sign in and so I can see my profile on addons.mozilla.org
(Reporter)

Comment 1

2 years ago
I recently cleared cookies so I now need to sign in but the page dose not load so I can't look at my collection and favourite pages on this old release. I need to use this version of Firefox occasionally because of some add ons not available it later versions. I realise this is not a supported version of Firefox but the accounts login page use to work fine. This is a simple login page does it work on older browsers versions ?
(Reporter)

Updated

2 years ago
Summary: Unable to signin on accounts.firefox.com → Unable to use signin page - accounts.firefox.com
(Reporter)

Comment 2

2 years ago
The page shows spinning blue circle in middle on blank page with  https://accounts.cdn.mozilla.net/images/542fcd95.mozilla.svg in top right corner. I can sign in on Google chrome browser on same desktop pc. Tried running Firefox in safe mode and got same result. Do you see same issue?
(Reporter)

Comment 3

2 years ago
Noticed console message:
[03:06:29.031] Content Security Policy: Failed to parse unrecognized source 'sha256-9n6ek6ecEYlqel7uDyKLy6fdGNo3vw/uScXSq9ooQlk='
[03:06:29.322] GET https://accounts.firefox.com/experiments.bundle.js [HTTP/1.1 200 OK 281ms]

"experiments" caught me attention.

Updated

2 years ago
Component: Untriaged → Server: Firefox Accounts
Product: Firefox → Cloud Services
Version: 25 Branch → unspecified
> Firefox/25.0
> [...]
> Content Security Policy: Failed to parse unrecognized source

I suspect this version of Firefox is too old to correctly interpret the CSP headers we're sending out; Shane can you confirm?
Flags: needinfo?(stomlinson)
(Assignee)

Comment 5

2 years ago
Created attachment 8850594 [details]
FxA in Firefox 25
Assignee: nobody → stomlinson
Flags: needinfo?(stomlinson)
(Assignee)

Comment 6

2 years ago
Using Fx 25.0, I had no problem signing in to AMO via FxA. I attached a screenshot showing FxA fully loaded after clicking "Sign in" from AMO. It's possible one of your addons or extensions are interfering with FxA. If you disable all addons, does the problem still manifest? If you try with a new profile without any addons?

experiments.bundle.js is our homegrown A/B test infrastructure.

AFAIK, ionvalid CSP headers are ignored instead of causing a page to not render.
(Assignee)

Comment 7

2 years ago
Scott, can you attempt to sign in with all addons/extensions disabled, or with a new profile, to see if this problem still manifests?
Flags: needinfo?(relay12)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

3 months ago
(In reply to Shane Tomlinson [:stomlinson] from comment #7)
> Scott, can you attempt to sign in with all addons/extensions disabled, or
> with a new profile, to see if this problem still manifests?

started in safe mode all (addons/extensions disabled) open private browsing window and clicking "Register/Login" on https://addons.mozilla.org/en-US/firefox/ does not do anything.
Flags: needinfo?(relay12)
(Reporter)

Comment 9

3 months ago
(In reply to Scott R from comment #8)
I am now on v25.0.1 and still windows system. I also tested 
- started in safe mode (=no add ons active) + new private window + open https://accounts.firefox.com/signin signin successfully but AMO page still shows "login" button - should it show me logged in? 

- setup empty profile, manually disabled all plugins same result. 
here is a console log snapshot after  AMO page loads completes: https://pastebin.com/iuUACmpZ (no extra lines are added when I select login button)
  
If it is just specific to me is there any way to manual do the login (= paste url manually)?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

3 months ago
(In reply to Scott R from comment #9)
Further testing "More..." link after "Themes" in left hand corner was not working as well even in new profile. 

I found using "developer hub" link https://addons.mozilla.org/en-US/developers/)  that the login option works as expected and logs me in via FxA page. After doing that I can see AMO page shows my name indicating I am logged in but moving mouse over my name or clicking does not give me a menu selection for "My account","Tools", "logout" etc. Same issue with "More..." link.

As long as the developer hub page login continues to function I have a workaround.
(Reporter)

Updated

3 months ago
Summary: Unable to use signin page - accounts.firefox.com → AMO page signin link not working
(Assignee)

Comment 11

3 months ago
(In reply to Scott R from comment #10)
> (In reply to Scott R from comment #9)
> Further testing "More..." link after "Themes" in left hand corner was not
> working as well even in new profile. 
> 
> I found using "developer hub" link
> https://addons.mozilla.org/en-US/developers/)  that the login option works
> as expected and logs me in via FxA page. After doing that I can see AMO page
> shows my name indicating I am logged in but moving mouse over my name or
> clicking does not give me a menu selection for "My account","Tools",
> "logout" etc. Same issue with "More..." link.
> 
> As long as the developer hub page login continues to function I have a
> workaround.

Thanks Scott for following up with this issue as well as for providing
the extra info. It looks like over the past two years the original problem
has changed.

I am able to reproduce the problem redirecting from Addons to Firefox Accounts
thanks to the info you provided in the pastebin.

When I click the "Register or Log in" button on [1], I see this error in the console:

> SyntaxError: missing variable name @ https://addons-amo.cdn.mozilla.net/amo-062ce0461fd498402a65.js:1

I'm not sure why this would occur on Firefox 25 and not the current release, 
perhaps a script is not being loaded due to CSP, though this seems unlikely to
me given that a SyntaxError is raised. Rather, I suspect the source code
is compiled using Babel and the generated output uses some Javascript features
only available after Firefox 25.

If I load up Addons in Firefox 62, click the "Register or Log in" button so that
it redirects to Firefox Accounts, copy the URL and paste that into Firefox 25, I 
am able to sign in to Firefox Accounts as expected. The redirection back to 
Addons occurs, though I am not signed in to Addon, and because I started the 
flow in one browser and finished it in another, should not expect to be signed 
into Addons.

Combined with you mentioning that you *can* sign into FxA/Addons via the Developer
Hub, my hunch is the problem you are running into is within the Addons site rather
than FxA. I hate passing the buck, I have opened a summary of this issue in 
Github at [2].

Scott, if you are comfortable with your workaround, you can close the issue
as WORKSFORME or INVALID, however your workaround may not be there forever.

I'm curious, are you using Firefox 25 out of necessity?

[1] - https://addons.mozilla.org/en-US/firefox/
[2] - https://github.com/mozilla/addons/issues/797
You need to log in before you can comment on or make changes to this bug.