Closed Bug 1348687 Opened 4 years ago Closed 4 years ago

Move the menubar above the tabs when not Aero

Categories

(Thunderbird :: Theme, enhancement)

All
Windows
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 55.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(3 files, 1 obsolete file)

Now the menubar is on Windows always below the tabs, except on non-default themes like Classic and High Contrast.

We should switch this to *only* position it below the tabs when Win7 Aero is active. We moved it there because we had a lot of complaints of a bad readability. The newer Win versions have no Aero, so we don't need to let it below.
Attached patch menubar.patch (obsolete) — Splinter Review
Jörg, this week you can test it on Win10 and then back at home, on Win7. ;-)

The code is relatively simple. It moves the toolbar exchange code to Glass only. It also changes how the background-colors are set or not depending the OS version and if the window has a window titlebar or draw in titlebar is enabled.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8848905 - Flags: review?(jorgk)
OK, I'm on Windows 10 now. I have no idea how to configure the appearance. Is there Aero? What is Glass?

Without the patch, the menubar sits under the tabs, with the patch it sits on top (like with the personal tweak you provided).

Some comments: In the tweaked version the menubar goes right across the screen, with the patch it doesn't have the full width, which is ugly. In FF you can't see it since the tab background and the menubar background have the same colour. In the tweaked version the tab background is some sort of steel blue/grey, which is nice. In the patched version, it's just some grey. I liked the blue better. And the menubar should go all the way across, right?
Attached image With patch.
Attached patch menubar.patchSplinter Review
(In reply to Jorg K (GMT+1) from comment #2)
> OK, I'm on Windows 10 now. I have no idea how to configure the appearance.
> Is there Aero? What is Glass?

Aero is the name of the Win7 theme with the transparent windows. Glass, or more correctly -moz-windows-glass, is the selector for this. In about:config you can switch mail.tabs.drawInTitlebar to hide/show the window titlebar.

> Without the patch, the menubar sits under the tabs, with the patch it sits
> on top (like with the personal tweak you provided).
> 
> Some comments: In the tweaked version the menubar goes right across the
> screen, with the patch it doesn't have the full width, which is ugly. In FF
> you can't see it since the tab background and the menubar background have
> the same colour. In the tweaked version the tab background is some sort of
> steel blue/grey, which is nice. In the patched version, it's just some grey.
> I liked the blue better. And the menubar should go all the way across, right?

It should look like FX with the same background color as the tabbar background. Fixed in this version.

The background of your tweaked menubar is gray because the tweak simply exchanges the toolbar order with no other changes and it goes over the whole width but it isn't visible.

I propose you to use mail.tabs.drawInTitlebar=true then you can save the space the titlebar uses. The window is still draggable in the light blue area (also a test you can do) when the titlebar is hidden.
Attachment #8848905 - Attachment is obsolete: true
Attachment #8848905 - Flags: review?(jorgk)
Attachment #8849446 - Flags: review?(jorgk)
Tested on Windows 10: Looks good, however ...
mail.tabs.drawInTitlebar=true:  Menu above, menu and tabbar background are "steel blue" (a8cbdb).
mail.tabs.drawInTitlebar=false: Menu above, menu and tabbar background are grey.
Is the colour difference intentional? In FF it's always grey.

Another question: So in Windows 10 I don't need to switch appearance to test another Windows theme? If I do, please advise how. On Windows 7 I know how to switch themes.

P.S.: I like my titlebars ;-)
The "steel blue" was introduced to give feedback if the window is active or not. With titlebar enabled this isn't needed as the titlebar gives this feedback.

P.S.: For men it's hard to name colors. :-) <http://www.funnyjunk.com/funny_pictures/1889559/Man/>
Win10 has only the default theme and high contrast themes. HC themes can be enabled through Settings/Ease of Access/High Contrast.
Comment on attachment 8849446 [details] [diff] [review]
menubar.patch

I'm back on Windows 7 now. There I see no change:
Aero: menu below tabs, otherwise above, as intended.

On Windows 10 the menu is now above the tabs for the "regular" theme. Sorry, I forgot to check "High Contrast". I trust you've checked it.
Attachment #8849446 - Flags: review?(jorgk) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/8eeb5667420daba2148746b6b9e470d0d8ebc35d
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
You need to log in before you can comment on or make changes to this bug.