Scrolling horizontally stays blurry after the scrolling stops, until the user touches the window

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
P3
normal
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: julienw, Unassigned)

Tracking

55 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

8 months ago
This is on Firefox Android / Nightly (20170318110135)

STR:
1. Go on https://fr.m.wikipedia.org/wiki/Lignes_de_bus_RATP_de_100_%C3%A0_199#Ligne_169
2. Wait until the focus moves to the "169" part
3. Scroll horizontally with a momentum.

=> Sometimes it's not repaint at the end of the momentum move and stays blurry.

It's not always easy to reproduce. Sometimes it happens right away, but sometimes it doesn't reproduce because it isn't blurry in the first place.

I noticed the bug happens if:

* there is a momentum
* the move is stopped by the momentum end, not by hitting an edge.

If the scroll hits an edge and stops abruptly as a result, then it's correctly paint.
What device are you using? The screen size might be a factor here. I tried reproducing on my Z3C but was not able to. Do you see this on any other URLs?
Priority: -- → P3
Whiteboard: [gfx-noted]
(Reporter)

Comment 2

8 months ago
This is on a Z3C :)

and TBH I think it's now working. Let's close it and I'll reopen if I see it again.
(Reporter)

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.