ESR 52 will not launch on Ubuntu 16.10

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
a year ago
a year ago

People

(Reporter: andyj@macspares.co.za, Unassigned)

Tracking

53 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170319115445

Steps to reproduce:

Ubuntu 16.10  does not install  " firefox-52.0.1esr.tar.bz2 "

No other method found to install the ESR

( I need to use it for a bank account in South Africa (https://www.fnb.co.za)


Actual results:

I can Extract but it will not install


Expected results:

Either give a ppa or a plain .tar that can install using " .run " or " ubuntu software "

Updated

a year ago
Component: Untriaged → Installer
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
There is no installation step needed for that file. Just run ./firefox from the extracted directory.
(Reporter)

Comment 2

a year ago
does not Find ./firefox in terminal
Attemt to use firefox presents the following :

+++++++++++++++
root@andy-ubuntu16-10:/home/andy/Downloads/firefox# ./firefox
XPCOMGlueLoad error for file /home/andy/Downloads/firefox/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
root@andy-ubuntu16-10:/home/andy/Downloads/firefox# ls
application.ini     icons               libnssckbi.so      omni.ja
browser             icudt58l.dat        libnssdbm3.chk     platform.ini
chrome.manifest     libfreeblpriv3.chk  libnssdbm3.so      plugin-container
crashreporter       libfreeblpriv3.so   libnssutil3.so     precomplete
crashreporter.ini   liblgpllibs.so      libplc4.so         removed-files
defaults            libmozavcodec.so    libplds4.so        run-mozilla.sh
dependentlibs.list  libmozavutil.so     libsmime3.so       Throbber-small.gif
firefox             libmozgtk.so        libsoftokn3.chk    updater
firefox-bin         libmozsandbox.so    libsoftokn3.so     updater.ini
fonts               libmozsqlite3.so    libssl3.so         update-settings.ini
gmp-clearkey        libnspr4.so         libxul.so
gtk2                libnss3.so          minidump-analyzer
root@andy-ubuntu16-10:/home/andy/Downloads/firefox# firefox

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox:6899): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
ERROR - ContextualIdentityService - Unknown version found in /root/.mozilla/firefox/p3dlsppd.default/containers.json

(firefox:6899): LIBDBUSMENU-GLIB-WARNING **: Unable to get session bus: The connection is closed

(firefox:6899): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox:6899): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
1490175049373	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
1490175049813	addons.update-checker	WARN	Update manifest for webcompat@mozilla.org did not contain an updates property
1490175049925	addons.update-checker	WARN	Update manifest for aushelper@mozilla.org did not contain an updates property
1490175050002	addons.update-checker	WARN	Update manifest for e10srollout@mozilla.org did not contain an updates property
1490175050147	addons.update-checker	WARN	Update manifest for firefox@getpocket.com did not contain an updates property

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(firefox:6899): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Moving this to another component because it's not an installer bug (we do not have a Linux installer) and because my expertise is mostly Windows.

I can think of one thing that might be wrong though; did you accidentally download the 32-bit build instead of the 64-bit one?
Component: Installer → General
Summary: Ubuntu 16.10 install ESR (Extended support Release ) will not install → ESR 52 will not launch on Ubuntu 16.10

Comment 4

a year ago
(In reply to andyj@macspares.co.za from comment #2)
> does not Find ./firefox in terminal
> Attemt to use firefox presents the following :
> 
> +++++++++++++++
> root@andy-ubuntu16-10:/home/andy/Downloads/firefox# ./firefox
> XPCOMGlueLoad error for file /home/andy/Downloads/firefox/libmozgtk.so:
> libgtk-3.so.0: cannot open shared object file: No such file or directory
> Couldn't load XPCOM.

This sounds to me like your machine doesn't have GTK3 installed. Is that possible?

> root@andy-ubuntu16-10:/home/andy/Downloads/firefox# firefox

This will use `firefox` from your $PATH environment variable, rather than the one in the directory in which you extracted the archive file. It'll be using the executable from your distro.
Component: General → Untriaged
Flags: needinfo?(andyj)
IMHO, I don't think that 16.10 doesn't have GTK3, but Andy could you please check it anyways:
$dpkg -l libgtk2.0-0 libgtk-3-0 .

I concur with Matt comment 3 as the most likely scenario is that you got 32b version. Could you please retry getting the x64 tar.gz and try running it again.

Meanwhile, marking this bug as incomplete. Andy, feel free to reopen this bug once the additional details are provided.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

a year ago
andy@andy-ubuntu16-10:~$ dpkg -l libgtk2.0-0 libgtk-3-0 
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  libgtk-3-0:amd 3.20.9-1ubun amd64        GTK+ graphical user interface lib
ii  libgtk-3-0:i38 3.20.9-1ubun i386         GTK+ graphical user interface lib
ii  libgtk2.0-0:am 2.24.30-4ubu amd64        GTK+ graphical user interface lib

I Will check to make sure I have the 64 bit version and report back
Flags: needinfo?(andyj)
You need to log in before you can comment on or make changes to this bug.