All users were logged out of Bugzilla on October 13th, 2018

Add more priority levels to task definitions

RESOLVED DUPLICATE of bug 1364266

Status

RESOLVED DUPLICATE of bug 1364266
2 years ago
a year ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
At the moment, Taskcluster supports 2 priority levels: high and normal[1]. Last Friday, Releng had 4 releases in flight, and we hit an issue where the least important release + central were taking almost all the available workers. In order to avoid that, we would need a finer set of priority. :bhearsum pointed out Buildbot currently implements 6 levels, which are used this way[2]


[1] https://docs.taskcluster.net/reference/platform/queue/references/api#get-task-definition
[2] https://github.com/mozilla-releng/build-buildbot-configs/blob/7b71825e6b7081a6c7c8860b03e7a56e56656ef9/mozilla/master_common.py#L25

Comment 1

2 years ago
7 levels, 0-6 :)

Comment 2

2 years ago
Jonas, based on this, does this mean we need to get the claimWork rolled out to all workers before we can support > 2 priorities?
Flags: needinfo?(jopsen)
We definitely need claimWork rolled out for workerTypes with many workers... Maybe we can ignore small pools.

Afaik our current plan is 5 levels... The hard part is naming then all.. 5 is like lowest, low, normal, high, highest.

Other name ideas are welcome, numbers are generally bad as they are hard to order...
Flags: needinfo?(jopsen)
Is this resolved now?
Yup, it was added to the task definitions in bug 1364266
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364266
You need to log in before you can comment on or make changes to this bug.