[gui] Shouldn't offer release numbers for any branch other than 'central'

REOPENED
Unassigned

Status

Testing
mozregression
REOPENED
a month ago
a month ago

People

(Reporter: Kostas, Unassigned, Mentored)

Tracking

({good-first-bug})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=python])

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170316213829



I'm trying to find the regression range for bug 1348644 that I reported, found in current FF stable release: 52.0.1 x64 (in win10x64).
I'm using mozregression-gui 0.9.6.
The problem is that I can't bisect if the range is versions or dates


STR:
Launch Mozregression GUI, click "File" -> "Run a new bisection"
keep as it is: Application -> "Firefox",  Bits -> 64, Build Type -> opt
set Repository -> mozilla-release (https://i.imgur.com/n9WBAbb.jpg)
in the next screen select profile: (none), 
and then, e.g.:

either versions e.g. (https://i.imgur.com/dLWgeNB.jpg)
Last known good: 42 (release)
First known bad: 52 (release)

or dates e.g. (https://i.imgur.com/OxQG40S.jpg)
Last known good: 2016-03-19
First known bad: 2017-03-19

but in both cases I get e.g. "WARNING : Skipping build 2016-09-27: Unable to find build info) and eventually "Unable to find enough data to bisect".



PS. I managed to make the bisection -at least- begin, by defining the range using changesets (I used those for 
FIREFOX_51_0_RELEASE and FIREFOX_52_0_1_RELEASE, from https://hg.mozilla.org/releases/mozilla-release/tags ) (https://i.imgur.com/IPertKS.jpg)
Last known good: ea82b5e20cbb
First known bad: a38b8538f424
but after the 5th step (http://i.imgur.com/v0oUU5t.jpg)
unfortunately it resulted in this 404 error (http://i.imgur.com/6Qu5x4D.jpg),
and the final pushlog_url on the right (https://hg.mozilla.org/releases/mozilla-release/pushloghtml?fromchange=1f0fc9316e65cd171b03d4382b4c0f7443a258dc&tochange=d75a1dba431fd3e3e44cb06ce7f545f1a358948a)
gives way too many changesets pushed to be of use.



PS. I also tried its default settings (not selecting a specific 'Repository', i.e. using mozilla-central) and then: 
Last known good: 2016-03-19
First known good: 2017-03-19
but I couldn't find the range (I marked all builds as 'good').
(Reporter)

Comment 1

a month ago
I noticed Alice0775 found the regression range (https://bugzilla.mozilla.org/show_bug.cgi?id=1348644#c3) :
https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=e293c1aa1c10d38b271b48742650d97a4ee5061e&tochange=93b639dcd0c2c6231932bdd8279dc858f6596bf6

so, I tried (based on [1]) :
Repository: mozilla-beta
and then, set a range the changesets of FIREFOX_52_0b2_RELEASE and FIREFOX_52_0b3_RELEASE from https://hg.mozilla.org/releases/mozilla-beta/tags, 
0f339c1e154f, and
d171c36d4848
respectively
and I again got a 404 error after the 4th step: https://i.imgur.com/XYnz1Pq.jpg
but the regression range I found was the same as Alice0775.


[1] http://forums.mozillazine.org/viewtopic.php?p=14738772#p14738772
(Reporter)

Comment 2

a month ago
> but the regression range I found was the same as Alice0775.
With "regression range" I meant the final pushlog_url (of the 4th step, i.e. https://i.imgur.com/TZOlnVB.jpg).
(Reporter)

Comment 3

a month ago
The related bug for the 404 errors: bug 1334762
Hey :Kostas, could you try the just-released version 0.9.7 which fixes bug 1334762? I'm not 100% sure, but I think this might fix some of your problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Flags: needinfo?(rick3162)
Resolution: --- → DUPLICATE
Duplicate of bug: 1334762
Sorry, didn't mean to resolve this prematurely. Also, here's the URL for 0.9.7: https://github.com/mozilla/mozregression/releases/tag/gui-0.9.7
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

a month ago
:wlach
With 0.9.7 I no longer get the 404 error when defining the range using the above changesets.

But the issue remain: if the range is versions or dates, 
then I still get e.g. "WARNING : Skipping build xxxx-yy-zz: Unable to find build info) 
and eventually "Unable to find enough data to bisect".
Flags: needinfo?(rick3162)
(In reply to Kostas from comment #6)
> :wlach
> With 0.9.7 I no longer get the 404 error when defining the range using the
> above changesets.
> 
> But the issue remain: if the range is versions or dates, 
> then I still get e.g. "WARNING : Skipping build xxxx-yy-zz: Unable to find
> build info) 
> and eventually "Unable to find enough data to bisect".

I'm sorry, I didn't read your original bug report closely enough. 

I think your problem is likely that you're trying to bisect against the mozilla-release repository. Using release numbers doesn't really make any sense with that repository (they're based off of branch dates when nightly moves to aurora). Try using the release numbers with the default branch (or mozilla-central) and I think you'll have a much better time.

That said, bisecting mozilla-release branch with the dates you mention should work, so I think there's still a bug here.
(Reporter)

Comment 8

a month ago
> I think your problem is likely that you're trying to bisect against the mozilla-release repository. Using release numbers doesn't really make any sense with that repository (they're based off of branch dates when nightly moves to aurora).
So, I'd suggest the following for Mozregression GUI: 
the two drop-down lists in the screen where the user defines the bisection range, 
to contain only the valid entries for the repo you have selected to bisect.
In my case not to show the 'release' entry (i.e. to only show: date, buildid, changeset) when bisecting mozilla-release.


> Try using the release numbers with the default branch (or mozilla-central) and I think you'll have a much better time.
(default branch = mozilla-central, right?)
And, yes, bisecting mozilla-central within the range of eg. versions 42 and 52 works ok.
(In reply to Kostas from comment #8)
> > I think your problem is likely that you're trying to bisect against the mozilla-release repository. Using release numbers doesn't really make any sense with that repository (they're based off of branch dates when nightly moves to aurora).
> So, I'd suggest the following for Mozregression GUI: 
> the two drop-down lists in the screen where the user defines the bisection
> range, 
> to contain only the valid entries for the repo you have selected to bisect.
> In my case not to show the 'release' entry (i.e. to only show: date,
> buildid, changeset) when bisecting mozilla-release.

I completely agree, let's morph this bug into solving that.
Summary: [gui] Unable to bisect Firefox for windows in mozilla-release repo if the range is versions or dates → [gui] Shouldn't offer release numbers for any branch other than 'central'
I could probably mentor this one if someone is interested: it should be just a little bit of PyQt programming. Ping me on this bug to ask for details.
Mentor: wlachance@mozilla.com
Keywords: good-first-bug
Whiteboard: [lang=python]
(Reporter)

Comment 11

a month ago
> I completely agree, let's morph this bug into solving that.

I'm glad you agree. I hope the following gets solved as well:
> bisecting mozilla-release branch with the dates you mention should work
(In reply to Kostas from comment #11)
> > I completely agree, let's morph this bug into solving that.
> 
> I'm glad you agree. I hope the following gets solved as well:
> > bisecting mozilla-release branch with the dates you mention should work

Ah right, that too. Filed bug 1351290.
You need to log in before you can comment on or make changes to this bug.