"mousedown" event behavior incorrect

RESOLVED INVALID

Status

()

Core
DOM: Events
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: bjornson, Unassigned)

Tracking

({regressionwindow-wanted, testcase-wanted})

55 Branch
regressionwindow-wanted, testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

Steps to reproduce:

Apologies in advance: I'm struggling to come up with a minimal reproducible example for this problem. I have, however, tested a lot of builds to help bisect the problem.

On Windows (10), "mousedown" doesn't fire in some unknown scenarios in FF55. The "click" event works. The elements with listeners are positioned divs nested pretty deeply in a single-page app. I can provide a guest login to a page showing the problem privately.

2017-03-20-unknown (54.0a2 latest Developer Edition): good
2017-03-20-03-02-09 (55.0a1 latest Nightly Edition): bad
2017-03-16-00-40-04 (54a2): good
2017-03-12-00-40-06 (54a2): good
2017-03-09-03-02-16 (55a1): bad
2017-03-08-00-40-20 (54a2): good
2017-03-07-07-04-55 (54a2): good
2017-03-06-15-03-46 (54a2): good
2017-03-06-15-03-42 (55a1): bad
2017-03-06-08-06-37 (54a1): bad
2017-03-04-03-02-05 (54a1): bad
2017-03-02-03-02-06 (54a1): bad
2017-03-01-03-02-02 (54a1): good

That is, this broke on 2-Mar in v54a1, is fixed in v54a2 and is still broken in v55a1-latest.

Is that actionable at all?
(Reporter)

Updated

a year ago
Component: Untriaged → Untriaged
Product: Firefox → Core

Comment 1

a year ago
(In reply to bjornson from comment #0)
> Is that actionable at all?

With a testcase, probably. :)
Flags: needinfo?(bjornson)
Keywords: regressionwindow-wanted, testcase-wanted
Hello bjornson, could you please provide a simplified test-case in order for us to test this further? Also feel free to use https://jsfiddle.net/ if the tools provided here are enough for you to give us a test case for the issue you are encountering.
(Reporter)

Comment 3

a year ago
Hi all, sorry -- turns out this is because PointerEvent support is enabled by default in 55, and some other JS on the page was stopping propagation in a pointerDown listener.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bjornson)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.