many WARNING: 'NS_FAILED(rv)' at toolkit/components/telemetry/TelemetryHistogram.cpp, line 2284

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: keeler, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

I'm seeing a lot of this in the console when running a local build of Nightly:

[Parent 2111] WARNING: 'NS_FAILED(rv)', file /home/keeler/mozilla-unified/toolkit/components/telemetry/TelemetryHistogram.cpp, line 2284

STR seems to be run Nightly, visit an https page, open the page info dialog, close Nightly (not sure if any of these are necessary except the first one...)

The failing code in question appears to be:

    nsresult rv = internal_GetHistogramEnumId(h->histogram_name().c_str(), &id);

I printed out h->histogram_name().c_str() to see if it was the same thing each time or something different, and there doesn't seem to be much of a pattern:

DOM_SCRIPT_SRC_ENCODING#UTF-8
MAIN_THREAD_RUNNABLE_MS#Anonymous_interface_timer
MAIN_THREAD_RUNNABLE_MS#Empty_microtask_runnable
...
sub#A11Y_INSTANTIATED_FLAG#content
sub#A11Y_ISIMPLEDOM_USAGE_FLAG
...
sub#XUL_CACHE_DISABLED
sub#XUL_CACHE_DISABLED#content

etc.

Comment 1

2 years ago
Weird. I don't suppose you have telemetry turned on for this build? (MOZ_TELEMETRY_REPORTING=1, or the FHR checkbox ticked on in your settings...)
about:telemetry says FHR is enabled but extended telemetry is disabled. I didn't specifically set MOZ_TELEMETRY_REPORTING=1, so it's whatever the default is. Also, I can reproduce in a fresh profile, so it isn't because I flipped any prefs.
This must have been bug 1120409, which was backed out.
Please re-open if you still see this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.