[Regression] Add search provider from a web site is not working

VERIFIED FIXED

Status

()

Firefox for iOS
Browser
P1
normal
VERIFIED FIXED
7 months ago
5 months ago

People

(Reporter: isabel_rios, Assigned: justindarc)

Tracking

({regression})

unspecified
Other
iOS
regression

Firefox Tracking Flags

(fxios8.0+, fxios-v8.0 verified)

Details

(Whiteboard: [MobileCore])

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
This is failing in XCUITests in latest master d22e8dc96 (March20th) but not in master ad1c1860b (March17th). Could be a regression introduced by one of the two latest commits. Investigating this further.

Steps:
1.Go to "https://developer.mozilla.org/en-US/search"
2.Tap on the Search field
3.Tap on the Add Search icon (magnified glass icon+)

Expected:
3.A pop up is shown asking: Add Search Provider? with two options "OK" or "Cancel"
4.Tapping on OK will add the new search provider

Actual:
3.There is a pop up: Failed. The search provider could not be added.

Note: Also tested with another website: www.wordreference.com
(Reporter)

Updated

7 months ago
tracking-fxios: --- → ?
(Reporter)

Comment 1

7 months ago
Created attachment 8849573 [details]
Captura de pantalla 2017-03-21 a las 16.45.11.png
Assignee: nobody → irios.mozilla
(Reporter)

Updated

7 months ago
Assignee: irios.mozilla → nobody

Updated

7 months ago
Keywords: regression
tracking-fxios: ? → 8.0+
Priority: -- → P2
Whiteboard: [MobileCore]
(Assignee)

Updated

7 months ago
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED

Updated

7 months ago
Iteration: --- → 1.19
Priority: P2 → P1
(Reporter)

Updated

7 months ago
Blocks: 1353431
(Reporter)

Comment 2

7 months ago
This issue seems to be fixed now on master (28b0fac8b658a0c6e5838293b2ed4124fdf72efc), it is not reproducible anymore.
Will close it, please re-open if can be reproduced again. 

XCUITests will be re-enabled shortly.

Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED

Comment 3

5 months ago
Verifying as fix on master b3b12590bebb48.
Status: RESOLVED → VERIFIED
status-fxios-v8.0: --- → verified
You need to log in before you can comment on or make changes to this bug.