Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1344580
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: achronop)

Tracking

({crash})

54 Branch
Unspecified
macOS
Points:
---

Firefox Tracking Flags

(firefox54 affected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-f3676963-dacf-4d74-95c2-17daf2170321.
=============================================================

Seen while looking at Mac crash stats - http://bit.ly/2mQKuql. Crashes seem to have started using 20170310004008. Most of the crashes are on OS X 10.10.

Assuming this might be related to Bug 1342363.
Assignee: nobody → achronop
Bug 1345049 landed 2017-03-10
chunmin can you have a look. It's the crash in layout init.
Flags: needinfo?(cchang)
I suspect it's related to |auto_channel_layout|[0] so I replace it by unique_ptr[1]. The current code should be updated[2] in bug 1345049. I think we need to land the updated code into Firefox 54? 

[0] https://hg.mozilla.org/releases/mozilla-aurora/annotate/0496e366a8f4/media/libcubeb/src/cubeb_audiounit.cpp#l142
[1] https://github.com/kinetiknz/cubeb/commit/f1a6eed0ef1829ea3ac589feefa0f46bf594cdaa
[2] http://searchfox.org/mozilla-central/rev/0079c7adf3b329bff579d3bbe6ac7ba2f6218a19/media/libcubeb/src/cubeb_audiounit.cpp#142
Flags: needinfo?(cchang) → needinfo?(mozillamarcia.knous)
We should move the discussion to bug 1344580
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344580
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.