Publish images with an html document messes up image links.

VERIFIED FIXED

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: michael wendell, Assigned: Brade)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This bug was found while verifying 133803.

If you try to upload an image to a subdirectory on an FTP server, the HTML page
does not point to the correct place.

Steps to Reproduce:
1. Launch Composer
2. Create a simple page with two lines of text and one image
3. Click on File - Publish As
4. Fill in all the appropriate information for your FTP server
5. Make sure to check the boxes to "Include images and other files" and "Use
this site subdirectory" Type the name of an image directory
6. Click Publish
7. Close out of the Publish confirmation dialog (if it is up) and change to the
HTML Source View of the document you just published.

Actual Results:
The html tag for the image is changed to: 
<img src="index.htmlbullet.gif" alt="text" width="10" height="10">Now navigate
to the page in the browser, and the image does not load properly.
Expected results:
I would expect that the URL be changed to something that was viewable, such as:
<img src="/images/bullet.gif">

Comment 1

16 years ago
This bug appears whether "Use this site subdirectory" is selected or "use same
location as page".  Tested on Win XP, build 2002040203.
(Reporter)

Comment 2

16 years ago
Changing summary.
Summary: Publish images in a subdirectory messes up image links. → Publish images with an html document messes up image links.
(Assignee)

Comment 3

16 years ago
This is probably my bug  -->brade
I assume all platforms...

The bug is probably part of bug 133591 (which hasn't landed yet but which I
tested against).
Assignee: cmanske → brade
Depends on: 133591
OS: Windows XP → All
Hardware: PC → All

Comment 4

16 years ago
yes, it's a dup

*** This bug has been marked as a duplicate of 133591 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

16 years ago
This does appear to have been fixed with 133591.

I am not seeing this problem with the 04-05 trunk build.

Comment 7

16 years ago
REOPENING to VERIFY as FIXED.

(This can't be a duplicate and dependent.)
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

16 years ago
RESOLVED/FIXED - per bug 133591 (since composer QA has to test this separately
from URL parsing in Necko, this is the best way).
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
VERIFIED: per sujay's comments above.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.