Closed Bug 1349467 Opened 3 years ago Closed 3 years ago

Bugfiler has problems to find the right component

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: cbook, Assigned: KWierso)

References

Details

Attachments

(1 file)

i guess its a regression, while trying to file a bug from a testfailure from treeherder resulted in  Bug Filer API returned status 400 (Bad Request) There is no component named 'Video/Audio' in the 'Core' product.  

i guess the right component is Audio/Video not Video/Audio :)
We're using in-tree metadata and that metadata has been wrong for 2+ years due to bug 1139087 and some others.

I'll fix this tomorrow by fixing the metadata.
https://dxr.mozilla.org/mozilla-central/search?q=video%2Faudio+file%3Amoz.build&redirect=true
Blocks: 1347764
Assignee: nobody → wkocher
Component: Treeherder → Build Config
Product: Tree Management → Core
Version: --- → unspecified
Comment on attachment 8850245 [details]
Bug 1349467 - Fix some Audio/Video BUG_COMPONENTs in moz.build files

https://reviewboard.mozilla.org/r/122894/#review125304
Attachment #8850245 - Flags: review?(jmaher) → review+
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b205a7ffecb8
Fix some Audio/Video BUG_COMPONENTs in moz.build files r=jmaher
https://hg.mozilla.org/mozilla-central/rev/b205a7ffecb8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.