Crash in nsMsgNewsFolder::RemoveMessage

VERIFIED FIXED in mozilla1.0

Status

P2
critical
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: mozilla-bugs, Assigned: Bienvenu)

Tracking

({crash})

Trunk
mozilla1.0
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3] have patch)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I failed to reproduce it so far, but it happened when I clicked on the list-ids
URL in the expired article (which created a new mailnews window) and while it
was processing it, I went back to the original MailNews window and clicked on an
IMAP folder (in a different account, obviously).

gdb says:

#0  0x41b2a8d7 in nsMsgNewsFolder::RemoveMessage () from
/usr/lib/mozilla/components/libmsgnews.so
#1  0x41b08329 in nsNNTPArticleList::AddArticleKey () from
/usr/lib/mozilla/components/libmsgnews.so
#2  0x41b1a8f1 in nsNNTPProtocol::SendListGroupResponse () from
/usr/lib/mozilla/components/libmsgnews.so
#3  0x41b1b1b7 in nsNNTPProtocol::ProcessProtocolState () from
/usr/lib/mozilla/components/libmsgnews.so
#4  0x418c50c1 in nsMsgProtocol::OnDataAvailable () from /usr/lib/libmsgbaseutil.so
#5  0x40743f71 in nsOnDataAvailableEvent::HandleEvent () from
/usr/lib/mozilla/components/libnecko.so
#6  0x407326db in nsARequestObserverEvent::HandlePLEvent () from
/usr/lib/mozilla/components/libnecko.so
#7  0x4017dd1f in PL_HandleEvent () from /usr/lib/libxpcom.so
#8  0x4017e16c in PL_ProcessEventsBeforeID () from /usr/lib/libxpcom.so
#9  0x411aae69 in processQueue () from /usr/lib/mozilla/components/libwidget_gtk.so
#10 0x4014e37d in nsVoidArray::EnumerateForwards () from /usr/lib/libxpcom.so
#11 0x411aaea7 in nsAppShell::ProcessBeforeID () from
/usr/lib/mozilla/components/libwidget_gtk.so
#12 0x411b1f9d in handle_gdk_event () from
/usr/lib/mozilla/components/libwidget_gtk.so
#13 0x40365d7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#14 0x40399773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#15 0x40399d39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#16 0x40399eec in g_main_run () from /usr/lib/libglib-1.2.so.0
#17 0x402b4333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#18 0x411aabd6 in nsAppShell::Run () from
/usr/lib/mozilla/components/libwidget_gtk.so
#19 0x4118a9f6 in nsAppShellService::Run () from
/usr/lib/mozilla/components/libnsappshell.so
#20 0x08051ea1 in DoCommandLines ()
#21 0x08052763 in main ()
#22 0x404f7627 in __libc_start_main (main=0x8052618 <main>, argc=1,
ubp_av=0xbffff8c4,
    init=0x804ca2c <_init>, fini=0x8053ddc <_fini>, rtld_fini=0x4000dcc4
<_dl_fini>, stack_end=0xbffff8bc)
    at ../sysdeps/generic/libc-start.c:129
(Reporter)

Comment 1

17 years ago
P.S. BuildID 2002033118 on RedHat Linux 7.2+updates.
Keywords: crash
(Assignee)

Comment 2

17 years ago
Stephen/Seth, this is a dup, right?
I haven't experienced a crash, not seen a bug filed with that particular stack
yet, so I'd have to say no.
QA Contact: gayatri → stephend
(Assignee)

Comment 4

17 years ago
oh, yes, I see what probably happened - we probably closed the db out from under
the news folder when you clicked on a different folder.
Component: Mail Database → Networking - News
(Assignee)

Comment 5

17 years ago
Created attachment 77293 [details] [diff] [review]
proposed fix

call GetDatabase to make sure the db is open.
Comment on attachment 77293 [details] [diff] [review]
proposed fix

sr=sspitzer
Attachment #77293 - Flags: superreview+

Updated

17 years ago
Attachment #77293 - Flags: superreview+ → review+

Comment 7

17 years ago
Comment on attachment 77293 [details] [diff] [review]
proposed fix

r=naving
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 8

17 years ago
Nominating, it's a crash, and trivial to fix.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Whiteboard: have patch

Comment 9

17 years ago
Marking [adt3] because I don't think this scenario is too likely, but since it's
a crash and a pretty simple fix, I think we should take it.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Whiteboard: have patch → [adt3] have patch

Comment 10

17 years ago
forgot to add the adt1.0.0 nomination.
Keywords: adt1.0.0

Comment 11

17 years ago
adt1.0.0+ (on ADT's behalf) approval for checkin to 1.0. Fixing
crashers improve our stability story.
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Comment 12

17 years ago
Comment on attachment 77293 [details] [diff] [review]
proposed fix

check sr box for Seth.
Attachment #77293 - Flags: superreview+

Comment 13

17 years ago
Comment on attachment 77293 [details] [diff] [review]
proposed fix

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #77293 - Flags: approval+
(Assignee)

Comment 14

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
I've tried reproducing this with 2002-04-08-08 and a newsgroup that expires
articles quickly using the testcase in comment #1.

I can no longer reproduce this on Linux, Mac OS X and Windows 2000.

For the trunk, this was the only incident (well, 2 of them, but it was the same
reporter):

http://climate/reports/searchstacksignature.cfm?stacksig=nsMsgNewsFolder%3A%3ARemoveMessage

 2002032610   MozillaTrunk   Windows NT 5.0 build 2195   2002-04-02 03:38:03  
nsMsgNewsFolder::RemoveMessage 521aa5dd

All of the other crashers with this stack were with the MozillaBranch.

Verified FIXED
Status: RESOLVED → VERIFIED
Adding verified1.0.0 to get off queries.
Keywords: verified1.0.0
Product: MailNews → Core
Product: Core → MailNews Core

Updated

4 years ago
Blocks: 1071918
No longer blocks: 1071918
You need to log in before you can comment on or make changes to this bug.