Loading Multiple iPIX content Sites w/98 and ME causes freeze

VERIFIED DUPLICATE of bug 85710

Status

()

P1
blocker
VERIFIED DUPLICATE of bug 85710
17 years ago
16 years ago

People

(Reporter: bmartin, Assigned: peterl-bugs)

Tracking

Trunk
mozilla1.0
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Loading iPIX content in 98 SE and ME causes Mozilla 099 to freeze

A 100% reproducible test is:
1. Install Mozilla 099 3/28 trunk
2. Install latest iPIX plug-in
3. Install Java JRE 1.3.1_02
2. Go to http://www.ipix.com/demo/outdoor/index.html
3. Select the Canoeing option

Results:
Mozilla will freeze up
Additionally, you may encounter Java not working after the xpi installation to
Mozilla.  The reason for this is their xpi installer is not placing NPOJI600.dll
into the Mozilla\plugins\ directory as expected.  User must manually copy this
file from c:\program files\Javasoft\ directory.

Here are additional notes extracted from Bugscape bug: 12953

------- Additional Comment #8 From Peter Lubczynski 2002-04-01 08:06 -------

It's going to take me some time to get this setup going. It works perfectly fine
on my WinXP with JRE 1.3.1 and a debug trunk except for this error message in
the Java console on one of the reloads:
java.lang.NullPointerException
	at sun.awt.windows.WGraphics.drawImage(Unknown Source)
	at hm35.paint(JAX)
	at hm35.run(JAX)
	at java.lang.Thread.run(Unknown Source)
Opening http://www.ipix.com/demo/outdoor/opening.mvr

Some more questions for Brent and Shrirang:
1. Set Java console debug level to '5' then visit the page, what's the last
thing to get outputed before the freezup?

2. In autoexec.bat, "set NSPR_LOG_MODULES=Plugin:8" and 
"set NSPR_LOG_FILE=c:\pluginlog.txt". Attach the file here.

3. Does the 1.0 trunk work better (mozilla 0.9.9 is NOT the trunk)? Maybe there
is a fix in the trunk and not 0.9.9.

Thanks!



------- Additional Comment #9 From Peter Lubczynski 2002-04-01 08:42 -------

Is this bug related to:
http://bugzilla.mozilla.org/show_bug.cgi?id=129680

------- Additional Comment #10 From Michael Dunn 2002-04-01 09:19 -------

Peter -- Why does this bug not occur with the 094 talon build which uses the
same JRE? Per AOL this is new since 099.



------- Additional Comment #11 From Peter Lubczynski 2002-04-01 09:33 -------

Hm... I see the applet throwing a null pointer exception on WinXP when clicking
on "Canoeing" (with JRE 1.3.1):

java.lang.NullPointerException
	at hm35master.a4(JAX)
	at hm35master.a8(JAX)
	at hm35master.run(JAX)
	at java.lang.Thread.run(Unknown Source)

With JRE 1.4, I see this error message:
No audio device available. Free audio device and restart the browser.

Mozilla 0.9.4 builds are vastly different to mozilla 0.9.9 builds and it is
difficult to compare.

------- Additional Comment #15 From Peter Lubczynski 2002-04-01 16:34 -------

I think this may be a bug in IPIX's Java code or how it palys with Sun JRE. On
every platform with every JRE, the Java console shows errors coming out from the
applet. Win98 just happens to be the worst as it hangs.

A Sun employee give this reason for the hang on other testcases:
http://bugzilla.mozilla.org/show_bug.cgi?id=129680#c9



------- Additional Comment #16 From Michael Dunn 2002-04-02 12:01 -------

...This an absolute Beta stopper. 
Peter we need almost continuous updates. Again ... this is a
regression from 094 to 099 and the burden on us is to resolve if at all possible.



------- Additional Comment #17 From bnesse@netscape.com 2002-04-02 12:49 -------

Created an attachment (id=4989)
OS X stack of crash

Here's a stack I generated clicking on the canoe using the 2002040108 OS X
Commercial build.



------- Additional Comment #18 From Peter Lubczynski 2002-04-02 13:33 -------

This works perfectly in 0.9.4. It's a regression on the trunk. This happens on
Mac too. Brian Nesse and I are investigating. There is still no ETA.

Comment 2

17 years ago
This also worked on 0.9.7 with java 1.3.1 on Win98
(just for narrowing searches :-) )

Comment 3

17 years ago
Using the build from today (20020404) on win98, this is still a repro. I'm not 
sure if this will help, but I am attaching the content of the java console.

So, should we be closing the bugscape bug or what?
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
Created attachment 77670 [details]
java console content

Since this is throwing a null pointer exception, is this really us?

Comment 5

17 years ago
over to peterl
Assignee: beppe → peterl

Comment 6

17 years ago
For comments from Sun and IPIX, see:
http://bugscape.netscape.com/show_bug.cgi?id=12953

I think this is a dup of bug 85710.

*** This bug has been marked as a duplicate of 85710 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.