Closed Bug 13497 Opened 24 years ago Closed 24 years ago

{css2} top and bottom margins with overflow:auto/scroll lost

Categories

(Core :: Layout, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: ian, Assigned: troy)

References

()

Details

(Keywords: css2)

When overflow is 'auto' or 'scroll', the top and bottom margins of content
is forgotten. For example, in:

   <div style="background: green; overflow: auto; border: 1px solid; ">
      <div style="margin: 100px 0; border: 1px solid;">
      </div>
   </div>

...there will be no green visible. There should be two 100px high regions of
green in a black box, separated by a thin black line. Changing overflow to
'visible' in the outer DIV shows the desired result.

Another test case:
  http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/overflowmargins.html
Status: NEW → ASSIGNED
The problem is that vertical margins are being collapsed. It's hard to explain,
but it's because of the way scroll frame's work. I think the problem is that the
area frame needs the bit set that says it's a margin root (NS_BLOCK_MARGIN_ROOT)
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
QA Contact: petersen → chrisd
Status: RESOLVED → VERIFIED
Using 9/28 Apprunner with the text case provided, verified bug fixed regarding
top and bottom margin issue. Don't know whether the issue regarding the scroll
bars compromising the colored boxes is a bug but the margin issue is resolved.
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.