Crash on Sync, both iPad, iPhone

RESOLVED WORKSFORME

Status

()

Firefox for iOS
Sync
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: seth_aten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

70.85 KB, text/plain
Details
(Reporter)

Description

a year ago
Created attachment 8850176 [details]
Crashlog

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170316213829

Steps to reproduce:

(Re-)install Firefox for iOS to iOS 10.2 iPhone 6s(Never JB yet) or 8.4 iPad Air 2(JB).
Login to Sync account.
Wait for the end.


Actual results:

App crashed to home screen on both devices. Crash log from iPhone attached. 


Expected results:

Should have finishing syncing data, then been ready for use.
(Reporter)

Comment 1

a year ago
If I may speculate, likely issue with Sync engine or some data on my profile. I sync passwords, bookmarks, tabs and preferences between two pcs with zero issue. I doubt it is anything specific to my iDevices as they are two very different setups.
Can you try 7.0 currently in Beta? 

https://www.mozilla.org/en-US/firefox/ios/testflight
Flags: needinfo?(seth_aten)
(Reporter)

Comment 3

a year ago
Awaiting invite.
Flags: needinfo?(seth_aten)
7.0 is on the App Store now
I'm pretty sure this is one of the bugs fixed in 7.3, judging by the unsymbolicated stack.
(Reporter)

Comment 6

a year ago
Looks like it. Issue is fixed on my 10.2 iPhone, but not on my 8.4 iPad(since the update is not available for that iOS version). Oh well. Not willing to upgrade iPad.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.