Pressing Enter on "Switch to tab" suggestion for a full url match loads it in the current tab.

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
2 years ago
18 days ago

People

(Reporter: 684sigma, Unassigned)

Tracking

({regression})

50 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 wontfix, firefox-esr52 affected, firefox53 wontfix, firefox54 fix-optional, firefox55 affected, firefox65 affected)

Details

(Whiteboard: [fxsearch][switch-to-tab])

(Reporter)

Description

2 years ago
I have a problem with Firefox Beta 52. It also happens in Beta 53, Nightly 55. Doesn't happen in ESR 45.
Sometimes when I select "Switch to tab" suggestion in location bar and press enter, it loads url in current tab.
Here's how to reproduce it

1. Copy url "https://bugzilla.mozilla.org/show_bug.cgi?id=1344509", open new tab, navigate to that url.
2. Open new tab, paste the url into location bar.
3. Press Down arrow to select suggestion "Switch to tab", press Enter.

Result: url loads in current tab.
Expected: browser should switch to existing tab, as suggestion says.
(Reporter)

Updated

2 years ago
Has STR: --- → yes
Keywords: regression

Comment 1

2 years ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3fe5546bc877aa00eeb88dcf4adb38e12f82f14d&tochange=c35d8f056f6745e084a383ad3896afb8fd2facaa

Regressed by:
c35d8f056f67	Marco Bonardo — Bug 1292310 - Enter may wrongly confirm a mouse selected entry in the urlbar. r=adw
Blocks: 1292310
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
status-firefox52: --- → wontfix
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → affected
Ever confirmed: true
Flags: needinfo?(mak77)
Version: 52 Branch → 50 Branch
Flags: needinfo?(mak77)
Priority: -- → P2
Whiteboard: [fxsearch]
Too late for a fix for 53, fix-optional for 54, minor carryover regression.
status-firefox53: affected → wontfix
status-firefox54: affected → fix-optional
IS this still reproducible with recent key/mouse rework?
I just tried the steps from comment 0 and I don't see this any more. Probably fixed by bug 1295458.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Comment 5

23 days ago
Someone on reddit noticed this recently: 

https://new.reddit.com/r/firefox/comments/9xb80q/awesome_bar_navigate_to_tab_drop_down_list/

"Switch to Tab" works with partial URL matches and also full URL matches when clicked with the mouse but when using the keyboard a full match will load in the current tab instead of switching.
Status: RESOLVED → REOPENED
status-firefox65: --- → affected
Resolution: WORKSFORME → ---
Summary: Pressing Enter on "Switch to tab" suggestion loads url in current tab. → Pressing Enter on "Switch to tab" suggestion for a full url match loads it in the current tab.
Whiteboard: [fxsearch] → [fxsearch][switch-to-tab]
Thanks Kestrel, I see that too.  Did some debugging -- when handleCommand is called due to a click, this.value is correctly a switchtab action URL.  But when it's called due to an enter keypress, this.value is the plain URL of the switch-to-tab tab.  It may have something to do with our deferred enter keypress handling, but I don't immediately see how.
Status: REOPENED → NEW
... or the nsAutoCompleteController.cpp changes in https://hg.mozilla.org/mozilla-central/rev/c35d8f056f67 which Alice narrowed down in comment 1.
let's move the handling to bug 1507755 that is newer, this was reported as fixed in comment 4 and there may have been a new regression in the meanwhile.
Status: NEW → RESOLVED
Last Resolved: 2 years ago18 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.