Intermittent browser/base/content/test/tabs/browser_tabCloseProbes.js | Should only be 1 collected value. - 0 == 1 - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/tabs/browser_tabCloseProbes.js :: assertCount :: line 23

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: mconley)

Tracking

({intermittent-failure})

unspecified
Firefox 55
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

(Whiteboard: [stockwell fixed])

Attachments

(1 attachment)

This test landed as part of bug 1340842.
Blocks: 1340842
Component: General → Tabbed Browser
Flags: needinfo?(mconley)
45 failures in 898 pushes (0.05 failures/push) were associated with this bug in the last 7 days. 

This is the #28 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 17
* mozilla-inbound: 16
* mozilla-central: 7
* try: 3
* oak: 1
* graphics: 1

Platform breakdown:
* windows8-64: 21
* windows7-32-vm: 12
* osx-10-10: 12

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-03-20&endday=2017-03-26&tree=all

Updated

2 years ago
Whiteboard: [stockwell needswork]
18 failures in 188 pushes (0.096 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 10
* mozilla-inbound: 5
* mozilla-central: 2
* try: 1

Platform breakdown:
* windows7-32-vm: 11
* windows8-64: 4
* osx-10-10: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-03-29&endday=2017-03-29&tree=all
17 failures in 123 pushes (0.138 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 12
* autoland: 4
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 8
* windows8-64: 6
* osx-10-10: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-03-30&endday=2017-03-30&tree=all
29 failures in 146 pushes (0.199 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 10
* autoland: 8
* oak: 4
* mozilla-central: 3
* try: 2
* graphics: 2

Platform breakdown:
* windows7-32-vm: 17
* windows8-64: 8
* osx-10-10: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-03-31&endday=2017-03-31&tree=all
109 failures in 845 pushes (0.129 failures/push) were associated with this bug in the last 7 days. 

This is the #12 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-inbound: 43
* autoland: 40
* mozilla-central: 15
* oak: 5
* try: 3
* graphics: 3

Platform breakdown:
* windows7-32-vm: 58
* windows8-64: 31
* osx-10-10: 20

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-03-27&endday=2017-04-02&tree=all

Updated

2 years ago
See Also: → bug 1353061

Updated

2 years ago
See Also: bug 1353061

Updated

2 years ago
Duplicate of this bug: 1353061
26 failures in 147 pushes (0.177 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 10
* autoland: 10
* mozilla-central: 3
* oak: 2
* try: 1

Platform breakdown:
* windows7-32-vm: 19
* osx-10-10: 4
* windows8-64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-03&endday=2017-04-03&tree=all
15 failures in 134 pushes (0.112 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 6
* autoland: 5
* mozilla-central: 2
* try: 1
* oak: 1

Platform breakdown:
* windows7-32-vm: 10
* windows8-64: 3
* osx-10-10: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-04&endday=2017-04-04&tree=all
23 failures in 151 pushes (0.152 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 10
* autoland: 7
* mozilla-central: 3
* try: 2
* oak: 1

Platform breakdown:
* windows7-32-vm: 17
* windows8-64: 3
* osx-10-10: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-05&endday=2017-04-05&tree=all
Mike, can you take a look at this, thanks!
43 failures in 170 pushes (0.253 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 24
* autoland: 16
* try: 2
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 35
* windows8-64: 5
* osx-10-10: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-06&endday=2017-04-06&tree=all
(Assignee)

Comment 13

2 years ago
Finally reached this point in my queue! Will look at this tomorrow.
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Flags: needinfo?(mconley)

Comment 15

2 years ago
mozreview-review
Comment on attachment 8855808 [details]
Bug 1349787 - Make sure browser_tabCloseProbes.js waits for tabs to be fully open before closing them.

https://reviewboard.mozilla.org/r/127700/#review130482
Attachment #8855808 - Flags: review?(dtownsend) → review+

Comment 16

2 years ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/389893c52830
Make sure browser_tabCloseProbes.js waits for tabs to be fully open before closing them. r=mossop
32 failures in 185 pushes (0.173 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 19
* mozilla-inbound: 7
* try: 3
* mozilla-central: 2
* graphics: 1

Platform breakdown:
* windows7-32-vm: 29
* windows8-64: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-07&endday=2017-04-07&tree=all
Comment hidden (mozreview-request)
(Assignee)

Comment 21

2 years ago
It turns out that the transitionend event isn't reliable in some cases, but the _fullyOpen attribute appears to be, according to that last try push. So I'm going to land that.

Comment 22

2 years ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9a4d8de1808
Make sure browser_tabCloseProbes.js waits for tabs to be fully open before closing them. r=mossop
https://hg.mozilla.org/mozilla-central/rev/c9a4d8de1808
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
172 failures in 867 pushes (0.198 failures/push) were associated with this bug in the last 7 days. 

This is the #7 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* mozilla-inbound: 71
* autoland: 68
* mozilla-central: 17
* try: 10
* oak: 5
* graphics: 1

Platform breakdown:
* windows7-32-vm: 129
* windows8-64: 24
* osx-10-10: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1349787&startday=2017-04-03&endday=2017-04-09&tree=all
Assignee: nobody → mconley
Whiteboard: [stockwell needswork] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.