SVG element z-order incorrect when using group elements

RESOLVED DUPLICATE of bug 1141098

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 1141098
a year ago
a year ago

People

(Reporter: cedric, Unassigned)

Tracking

({regression})

17 Branch
Unspecified
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-Chrome][parity-Edge])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36

Steps to reproduce:

If you define elements in an inline svg in a certain order the elements should be rendered in exactly that order. This works in normal cases. It should work as well if these elements are inside a group element.


Actual results:

However if these elements are enclosed in a group element the z-index order seems to be messed up.
An example of this can be observed here: https://jsfiddle.net/hm9n9pgb/

(In case you don't observe the same behaviour this is a screenshot of Firefox with my setup: https://own.arrakiz.org/index.php/s/gn6XvLpUOSWLzyT )


Expected results:

The order of the elements should be the same no matter if they are enclosed in a group or not. View the above jsFiddle in Google Chrome and you will see that Chrome renders both cases identical.

(Again, here is a screenshot in Chrome: https://own.arrakiz.org/index.php/s/GvQIQ4GDFgPzU6S )

Updated

a year ago
Component: Untriaged → Untriaged
Product: Firefox → Core

Comment 1

a year ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a799b5bff84c&tochange=b077c43a4306

Regressed by:
b077c43a4306	Jonathan Watt — Bug 776054 - Flip the prefs to enable the use of display lists for SVG painting and hit-testing. r=roc.
Blocks: 776054
status-firefox52: --- → wontfix
status-firefox53: --- → fix-optional
status-firefox54: --- → fix-optional
status-firefox55: --- → affected
status-firefox-esr45: --- → wontfix
status-firefox-esr52: --- → affected
Component: Untriaged → SVG
Keywords: regression
OS: Unspecified → All
Whiteboard: [parity-Chrome][parity-Edge]
Version: 52 Branch → 17 Branch

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
duplicate of bug 1141098, no?

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox52: wontfix → ---
status-firefox53: fix-optional → ---
status-firefox54: fix-optional → ---
status-firefox55: affected → ---
status-firefox-esr45: wontfix → ---
status-firefox-esr52: affected → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1141098
You need to log in before you can comment on or make changes to this bug.