HTTP POST performance is miserable with large textbox values

RESOLVED DUPLICATE of bug 130301

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 130301
17 years ago
17 years ago

People

(Reporter: Nick Moffitt, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020320
BuildID:    Debian 0.9.9 package

When I edit a large document in the LNX-BBC wiki, mozilla spends forever working
on the submission.  The same thing happens with the mailman admindb page.  The
common element here is that both types of submissions have large text boxes with
huge amounts of data in them (entire documents or multi-kilobyte mail messages).

I would not classify this as a mozilla bug, but lynx submits these requests
remarkably faster than mozilla.  Mozilla will wait for ten to fifteen minutes to
send just a few K of text, while lynx will have it done in no time at all. 
Mozilla has no trouble *downloading* the textbox data, but *re-uploading it* in
the submit request lags like nobody's business!

I have noticed with the mailman pages that it seems to be much quicker when
you're on the same local net as the mailman machine.  Submitting over
ethernet/802.11b doesn't have the problem that submitting over an SDSL
connection does.

Reproducible: Always
Steps to Reproduce:
1. create a moderated mailman list on a machine on the other side of your
Internet connection
2. send lots of unauthorized messages through
3. Visit the admindb page (note download time)
4. approve or deny messages experimentally
5. Note submission time.
6. Repeat 2-5 with lynx

optionally
1. submit a large document to a page on a public MoinMoin server
2. click the "editpage" link at the bottom
3. note download time
4. make a small change and resubmit
5. Note upload time
6. Repeat 2-5 with lynx

Actual Results:  laaaag

Expected Results:  submitted in roughly the same time it took to download the
page in the first place.  In other words, have comparable performance to lynx.

In closing, it is utterly bogus that I should have to "register for an account"
just to file a goddamn bug.
(Assignee)

Comment 1

17 years ago
please upgrade to a more recent nightly build.  this regression has been fixed.

*** This bug has been marked as a duplicate of 130301 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.