Closed Bug 13499 Opened 21 years ago Closed 21 years ago

click on radio crashes pref

Categories

(SeaMonkey :: Preferences, defect, P1, critical)

x86
Other
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: matt, Assigned: mcafee)

References

Details

goto cache pane
click on everytime

crash

pref_HashPref(const char * 0x042369c0, PrefValue {...}, int 32, int 1) line 1806
+ 20 bytes
PREF_SetCharPref(const char * 0x042369c0, const char * 0x042340d0) line 727 + 17
bytes
pref_copyTree(const char * 0x032c8a08, const char * 0x032c9110, const char *
0x02736ff0) line 2189 + 13 bytes
pref_copyTree(const char * 0x032c8a08, const char * 0x032c9110, const char *
0x0271de94) line 2233 + 17 bytes
pref_copyTree(const char * 0x032c8a08, const char * 0x032c9110, const char *
0x032c8a08) line 2233 + 17 bytes
PREF_CopyPrefsTree(const char * 0x032c8a08, const char * 0x032c9110) line 2248 +
17 bytes
nsPref::CopyPrefsTree(nsPref * const 0x00a207b0, const char * 0x032c8a08, const
char * 0x032c9110) line 849 + 13 bytes
nsPrefWindow::SavePrefs(nsPrefWindow * const 0x031ae2b0) line 727
XPTC_InvokeByIndex(nsISupports * 0x031ae2b0, unsigned int 6, unsigned int 0,
nsXPTCVariant * 0x0067c82c) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x03e395c0,
nsXPCWrappedNative * 0x03fb93c0, const XPCNativeMemberDescriptor * 0x03fb9470,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 0, long *
0x027031e4, long * 0x0067ca48) line 507 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x03e395c0, JSObject * 0x02719cc8, unsigned
int 0, long * 0x027031e4, long * 0x0067ca48) line 170 + 34 bytes
js_Invoke(JSContext * 0x03e395c0, unsigned int 0, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x03e395c0, long * 0x0067d278) line 2228 + 15 bytes
js_Invoke(JSContext * 0x03e395c0, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x03e395c0, JSObject * 0x0263f2e8, long 40104688,
unsigned int 1, long * 0x0067d3d4, long * 0x0067d3e0) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x03e395c0, JSObject * 0x0263f2e8, long
40104688, unsigned int 1, long * 0x0067d3d4, long * 0x0067d3e0) line 2662 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x04235c30) line 110 + 40 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0067d5f4, nsIDOMEvent * * 0x0067d5bc, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 621 + 21 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x03a0c4a0, nsIPresContext
& {...}, nsEvent * 0x0067d5f4, nsIDOMEvent * * 0x0067d5bc, unsigned int 1,
nsEventStatus & nsEventStatus_eIgnore) line 2862
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0x03a1a6b0, nsIPresContext & {...}, nsMouseEvent * 0x0067d8f4, nsEventStatus &
nsEventStatus_eIgnore) line 864 + 31 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x03a1a6b0,
nsIPresContext & {...}, nsGUIEvent * 0x0067d8f4, nsIFrame * 0x03a1cba0,
nsEventStatus & nsEventStatus_eIgnore, nsIView * 0x039533d0) line 393 + 24 bytes
PresShell::HandleEvent(PresShell * const 0x03963d14, nsIView * 0x039533d0,
nsGUIEvent * 0x0067d8f4, nsEventStatus & nsEventStatus_eIgnore) line 2005 + 43
bytes
nsView::HandleEvent(nsView * const 0x039533d0, nsGUIEvent * 0x0067d8f4, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 835
nsViewManager::DispatchEvent(nsViewManager * const 0x0395c360, nsGUIEvent *
0x0067d8f4, nsEventStatus & nsEventStatus_eIgnore) line 1612
HandleEvent(nsGUIEvent * 0x0067d8f4) line 67
nsWindow::DispatchEvent(nsWindow * const 0x039505b4, nsGUIEvent * 0x0067d8f4,
nsEventStatus & nsEventStatus_eIgnore) line 332 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0067d8f4) line 353
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 3151 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line
3369
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 26017871, long *
0x0067db14) line 2388 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0000072c, unsigned int 514, unsigned int 0, long
26017871) line 401 + 27 bytes
KERNEL32! bff7363b()
KERNEL32! bff942e7()
0
Target Milestone: M7
testing another bug with this comment..
Target Milestone: M7
..
*** Bug 14141 has been marked as a duplicate of this bug. ***
Priority: P3 → P1
Target Milestone: M11
Who marked this P1?  How about a comment when doing so?  thanks.
don@netscape.com marked it P1 according to the View Bug Activity link.
Severity: normal → critical
crash -> critical severity
The pref does not crash, marking worksforme.
The pref also does not stick, filing another bug for that.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
seems to work for me now too
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.