Uninstalling WebExtensions extension does not remove extension data

RESOLVED DUPLICATE of bug 1213990

Status

RESOLVED DUPLICATE of bug 1213990
2 years ago
4 months ago

People

(Reporter: alexeiatyahoodotcom+mzllbgzll, Unassigned)

Tracking

50 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

Steps to reproduce:

When you uninstall a WebExtensions extension, the extension's data (chrome.storage.local, probably other stuff) is not removed. Reinstalling the extension picks up the old data, instead of starting from scratch.

This is breaks user expectations and makes it difficult to reset an extension without resetting the entire profile.

Also note that uninstalling an extension in Chrome, does properly clean up all of the extension's data.


Actual results:

The extension's data hangs around.


Expected results:

The extension's data should be removed.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213990

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.